Question
Reply
Highlighted
Tutor
Posts: 11
Member Since: ‎02-20-2013
Message 1 of 27 (5,568 Views)
Accepted Solution

XW8600 Drive Support

Hello all.

 

I have an XW8600 running dual X5440 processors and 6 GB of ram.  I want to turn this system into a home media NAS server runing FreeNas or Open Media Vault and have a few questions.

 

First off, I have read in a few places this system cannot handle 6 Gb/s SATA drives on its 3 Gbp/s ports.  I have upgraded the bios firmware of the board to the lastest version, and currently have a WD RED 2TB drive connected to one of the SATA ports and its running fine.  Windows Vista was on it for testing for a week, and Open Media Vault is currently on it and running for testing before jumping into the project head first.  Are these 6Gbp/s ddriver compatable as of yet?  Has the drive firmware issue been resovled ont hese newer drives?  I read here: http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c02711513&lang=en&cc=us&taskI... that HP has worked with the hard disk drive vendors so that all 6Gbps SATA hard drives provided by HP will work on 3Gb/s and 1.5Gb/s ports.  Have the other venders such as Western Digital included these fixes in their own firmware as well?  I plan on adding 4 or 5 more in total and before I drop the money on them I want to make sure I'm not going to run into issues.

 

My second question is - Can I run SATA drives in the SAS ports as well?  I know SAS is backwards comptable with SATA, but I am wondering if mixing SATA drives in the SATA ports and SATA drives in the SAS ports is going to cause problems.  I plan on creating two virtual disks in software RAID 5 - one for the SATA ports and a seperate VD for the SAS ports.  Will this be an issue?

Reply
0
Accepted Solution

Re: XW8600 Drive Support

Well I just want to update all in the future that find this thread and have a similar question.  I've been running the three WD Red 2TB drives in RAID 5 (software) now for three weeks using FreeNAS.  The system hasnt had any issues, no SMART errors or warnings and has just under 1 TB of data spread across the drives.  I'm going to say the its a win for me.  

View solution in context
Teacher
Teacher
Posts: 371
Member Since: ‎09-18-2011
Message 2 of 27 (5,549 Views)

Re: XW8600 Drive Support

The HP information on that is simple..... buy the drives from HP and you'll be OK.  I wish they would release their breakthrough, because the prior advisory indicated things would not work for sure.  I have seen no hint that they will release the firmware fix their engineers came up with to certify their SATA generation 3 drives to run reliably on the SATA generation 2 HP workstations.  It is not a BIOS update.  I can't blame HP for needing to get return on their engineering investment.

 

Having said that, you do have an alternative, which is to buy new SATA generation 2 drives.  The xw8600 won't run any faster on SATA generation 3 drives.

 

Make sure to add in a front fan if you don't have one already, for extra cooling if you load up on hard drives.  For the xw8400 and xw8600 the fans are almost identical throughout, and the supplemental front "PCI" fan is a 80x25 mm fan for both.  I have figured out a way to cheaply add in a nice Noctua non-PMW 92x25 mm front fan to the xw6400/xw6600 workstations without the expensive and hard to find front fan holders, and bet that will work on the xw8600.  Let me know if you're interested in lower noise.

 

I don't have any experience with the SAS to SATA question.......

 

Another tip..... the xw6600 has two PCIe x16 slots which are PCIe generation 2 slots unlike those in the xw6400 and xw8400.  I bet those two PCIe x16 slots on the xw8600 are generation 2 also.  I'm working on a project to get the latest HP USB 3.0 card running at full bandwidth on the lower of the two PCIe x16 generation 2 slot in my xw6600.  The same idea would work with a PCIe generation 2-to-SATA generation 3 card, I bet.  I do think that would get you around the SATA generation 3 hard drives on a SATA generation 2 HP workstation issue, because the controller chip would be on the card, not the motherboard.  There are some good articles out there on these type of cards.

 

Do you need 3.5" drives?  2.5" drives draw less power and you can fit more in, cooler.  There is a lot of room in there, as you know.  Try to stay away from the 2.1 TB limit... it is a bear to move above that but can be done if really necessary, as has been posted about here.

 

Keep us updated, please.... sounds interesting!

Tutor
Posts: 11
Member Since: ‎02-20-2013
Message 3 of 27 (5,528 Views)

Re: XW8600 Drive Support

Well I've spent most of the day testing and can say the xw8600 can handle Western Digital Red drives which are SATA III drives. I've plugged three of them in (started off with one for a week running vista and windows 7 with only one issue which was NIC related). Today I dropped the other two in the SATA ports while running Windows 7. They were all stand alone at this point. I stress tested them and the system for three hours. No issues to report on them.

After the above was complete I placed all the drives on SAS ports and did the same in both stand alone and in RAID 0. No issues came out of this either. It looks as if (at the very least) Western Digital has figured out how to get their 3rd gen drives to work on this board.

In the end I installed Open Media Vault on the system and placed the drives in a RAID 5 array, and mounted them within the OS (Debian based). They are currently up and running. No smart errors as of yet, none of the drives have dropped out of the array, and I'm currently transferring around 1.5 TB of data from an external drive onto them. I'll have to check it in the morning to see how everything is running. Going to be very picky about backups over the next while to ensure it keeps this up. I'm guessing because of the previously discussed issues with 3rd gen SATA drives that I'll be keeping this in the testing phase for a few weeks to a month before I'm comfortable with it.
Tutor
Posts: 11
Member Since: ‎02-20-2013
Message 4 of 27 (5,527 Views)

Re: XW8600 Drive Support

One thing I forgot to mention - I'll be picking up a fan I think a well. This is my first time using the WD Red drives, I usually use the WD Black. If you get you hands on a Red they run extremely cool. I'm stunned at how little heat they put off compared to other drives.
Teacher
Teacher
Posts: 371
Member Since: ‎09-18-2011
Message 5 of 27 (5,517 Views)

Re: XW8600 Drive Support

That is great news on the WD Reds..... would you post the exact model number you are using for future reference here?

 

The front fan:  You may already have the black plastic front fan holder that a 80x25mm fan will snap into.  From HP those are PWM speed controlled, and they run slower by default than if they received full 12v without PWM throttle.  Why they did not put in 92x25mm fans is beyond me.... there is more than enough room.

 

My favorite 92mm fan, if you choose to not use or don't have the fan holder is to mount a Noctua 92mm NF-B9 case fan up front with 1.5" stainless wedge head philips drive stainless #6 screws thru the front case perforation case holes.  I use a #10 fender washer on the outside of the holes, and the #6 wedge head settles nicely down into that.  You can also use a metric fender washer.  I get this stuff stainless from Ace Hardware.  Nylock nut on the inside, atop a regular #10 washer, atop a chromed wire fan grill from the inside.  Air flow is from the out to in.  For the xw6400/6600 cases I can only get 3 of the 4 fan holes to line up, and so I only use 3 screws total.  I don't overtighten..... just snug.  Those Noctua come with in-line rpm reducers..... I use the LNA, or a ULNA if I really want things quiet.  You may wish to use none.... the lead is long enough without.

 

4-pin motherboard header is right there for you....... just shave off the thin lip on the yellow wire side of the fan plug and the plug will slip onto pins 1-3 of the motherboard header just fine.  It will run at the Noctua stated speeds for 12v depending on what adapter you may or may not choose to use.  They do make a PWM 92mm fan, but the HP PWM control makes that run quite slow by default.

 

This is much cheaper than trying to track down one of the black plastic fan holder inserts if you don't have one in the case already.

 

http://www.noctua.at/main.php?show=productview&products_id=16&lng=en

 

 

Tutor
Posts: 11
Member Since: ‎02-20-2013
Message 6 of 27 (5,515 Views)

Re: XW8600 Drive Support

I'll look into the fans today.  The model for the WD Red drives im using is WD20EFRX.  They're specificly made for NAS servers.  I'll keep this thread updated with my progress on it and any issues that arrise.  

 

To summarized - WD RED SATA III 6 Gbp/s HDD's work in the xw8600 on both SATA and SAS ports, as stand alone drives and in the xw8600 onboard RAID arrays.  Mixed use SAS and SATA has not been tested. I highly doubt they will work when in mixed SAS and SATA ports as I have yet to find a system that will allow this.

 

So far from what I can gather these are the only 3rd gen SATA drives that arent from HP that will actually work in this system

Tutor
Posts: 11
Member Since: ‎02-20-2013
Message 7 of 27 (5,455 Views)

Re: XW8600 Drive Support

Well I just want to update all in the future that find this thread and have a similar question.  I've been running the three WD Red 2TB drives in RAID 5 (software) now for three weeks using FreeNAS.  The system hasnt had any issues, no SMART errors or warnings and has just under 1 TB of data spread across the drives.  I'm going to say the its a win for me.  

Teacher
Teacher
Posts: 371
Member Since: ‎09-18-2011
Message 8 of 27 (5,441 Views)

Re: XW8600 Drive Support

Sapper,

 

Thanks much for that followup.  I've attached the WD Red Drive PDF datasheet.

 

The 1 and 2 TB drives wil be great to have available in the xw6400, xw8400, xw6600 and xw8600 workstations.  Moving up to the 3 TB drives in those can be quite the hassle.  I did finally figure out how to get full 3TB drives to be recognized as a single partition in these workstations, and posted here on that.

 

One idea for owners of xw6600 and xw8600 workstations:  The primary (video card) and secondary (lower) PCIe x16 slots in those are both PCIe generation 2 slots, unlike those in the xw6400 and xw8400 (which are both generation 1 slots).  There are PCIe SATA cards that can be plugged into the generation 2 slots that provide full speed data access to SATA generation 3 hard drives.

 

Using one of those cards in your lower PCIe x16 slot would be a great way to get access to the full bandwidth of those drives.  It also may be possible that the 3TB drives would work easily on those workstations through that pathway.

 

I'm using this basic concept to get full bandwidth use of a PCIe gen 2 USB 3.0 card in one of my xw6600's, and the speed benefit is amazing.

 

See attached PDF for the Red Drive datasheet.

Teacher
Teacher
Posts: 371
Member Since: ‎09-18-2011
Message 9 of 27 (5,376 Views)

Re: XW8600 Drive Support

Update on the Western Digital Red drives.  I went ahead and got one of the 1TB WD Red drives to have in one of my xw workstatons (this one a xw6600) with a boot/application Intel SSD (older one) and the Red as the storage drive for files, etc.  W7Pro 64-bit install.

 

I had read that WD has a hidden partition of about 230 MB in there for software that has caused some in the Mac world problems.  The Reds are SATA Generation 3 drives, and the xw workstatons are

SATA Generation 2 workstations, and HP has cautioned that only their SATA Generation 3 drives can be reliably used (they apply some form of firmware fix that HP developed which lets the G3 drives be cross compatible with SATA G2 workstations).

 

The WD Red was recognized as a raw drive out of the box by the Windows 7 Disk Management utility, and as a drive under Device Manager.  I created a single MBR partition on it, did a long version NTFS default format, and the drive appeared normal under Disk Management.  However, on cold reboot it would not mount on the desktop (it never had initially after the format, either).  Still present in Device Manager and Disk Management.  Just not showing up on the desktop.

 

Having read about the Mac problems with this drive related to the reported hidden WD partition I got out my bootable DBAN CD.  This does a very low level reformat and clears areas of hard drives that I have not been able to clear otherwise.  The .iso to burn this CD from is easy to find as a free download under google search for DBAN or Dukes Boot and Nuke, and I've used that for years.  Booted into that CD, choose the interactive mode, selected that 1TB hard drive (be careful at this step, of course, because it will see all attached drives and you're one mistake away from nuking the wrong one), and let it run for the multiple hours it takes.  Then, rebooted into W7 off the SSD, and the WD Red drive showed up in Disk Management, again raw.  Did the long version default NTFS format (MBR again chosen, not GPT type drive selected at the very outset).

 

On reboot after that was finished the drive finally shows up properly on the desktop, and is working fine.  This seems to support the Apple guys reports of problems related to the hidden WD partition, and that DBAN can wipe that.

 

This is early in the experiment, but things look good using this technique for preparing a WD Red to use as a single file storage drive above a SSD in xw workstations.  I'll be backing up frequently.

 

If anyone else tries this process it woudl be valuable to post your results here for help in confirming the problem, and its solution, on the xw workstations.

 

Scott

Top Student
Posts: 6
Member Since: ‎03-25-2014
Message 10 of 27 (5,208 Views)

Re: XW8600 Drive Support

FWIW I have an HP XW 8600 latest BIOS drivers etc, running Windows Server 2008 R2 with this Hitachi Drive HDS723020BLA642 which is a 2 TB SATA 6.0Gb/s running fine, about to replace this 2 TB with a 4 TB WD4001FAEX will post if there are issues. Using GPT BTW

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation