Question
Reply
 
Top Student
coleco
Posts: 9
Member Since: ‎11-29-2012
Message 1 of 1 (709 Views)

Elgato game capture hd doesnt work on new HP but works fine on my laptop, Freezing issues in past.

Just bought a elgato Game capture.  I have an H8-1100z amd fx 6100 with windows 7 64 bit and amd 6670 card.  It has a 600 watt power supply,  everything was custom built from here and i have done no overclocking or alterations.  The software always says "Capture device not detected"

 

Reinstalled software, reinstalled usb root hubs doesnt work.   When I plug cable into Acer i5 laptop  with same OS works fine.  Every other usb device works fine, tested a smartphone and external drive today. I have been having some intermitent freezes in the past (not for a while) where everthing including power to mouse and keyboard is out (ctrl alt delete doesnt even work). BSOD 's once and said USB bugcode error, everything been fine for a month but this new elgato isn't working.  I have never formatted drive for important things that Need codes like software are on it.  Microsoft virus scan is clean.

 

Usb cable is in tight made a unlisted video of how it works fine on my laptop which has weaker specs, while I plug right back into HP and wont capture. This is a new computer and Don't understand why Elgato says no capture device detected. Here is the video  http://www.youtube.com/watch?v=mqvbR8fAiW8

 

Computer is less than a year old and I bought this computer for this purpose mainly.  I bought it from here the warranty is still on, any known issues with lack of power supply?  I unplugged everything besides elgato,  tried every port, including ones in the back no response, tried a different usb cable etc.  Restarted software. reinstalled several times. This product is very popular and has good reviews from most everyone.

 

Please help thanks.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation