Question
Reply
 
Top Student
figureguy
Posts: 5
Member Since: ‎04-22-2009
Message 1 of 10 (12,099 Views)

System Fan Failure on Pavilion a1730n

Good morning.  Earlier today I booted up my Pavilion a1730n.  When it first came on, I received a black screen with the error message 'system fan failure please have PC serviced to prevent damage' or something very similar.  It asked me to press F2 to continue.  After shutting the system off, when I rebooted I noticed that both fans are spinning.  After a couple more reboots, the error message only came on once out of 5.  I opened the case, checked connectors, and blew the fans with compressed air.  I did have the power off and my anti-static wrist strap on.  All the years I've had the computer this was the first time this happened.  I'm not sure what to do from here, and to be honest, I am not sure if the system fan is the one on the rear of the case or the one on the CPU.  Thanks in advance, any advice would certainly be appreciated.
Grad Student
sclui56
Posts: 273
Member Since: ‎10-06-2009
Message 2 of 10 (12,082 Views)

Re: System Fan Failure on Pavilion a1730n

System fan in your unit is the exhaust/case fan towards the back, the connector (SYS_FAN1) is the one towards the SW corner of the CPU looking at the following diagram:

 

MB

 

Following the same precautions in working in & around the unit, leave the side cover off, and try to observe if the case fan is rotating off-axis, stuck, or slow whenever the warning error appears. If you did not buy the extended warranty, your system is probably out of warranty. If the fan is bad, just remove the same & look at the specs, need to know the size in mm, height (less important), RPM, and # of wires, you should be able to get a replacement for under $10.

Top Student
figureguy
Posts: 5
Member Since: ‎04-22-2009
Message 3 of 10 (12,073 Views)

Re: System Fan Failure on Pavilion a1730n

Thank you so much for the diagram.  I will admit, I have installed graphics cards, memory, etc. but have never dealt with the fan issue.  As far as the specs, would I find those on the fan itself, by removing it?  When you said remove the same and look at the specs, I just wanted to be sure where I would find them on the fan itself.
Grad Student
sclui56
Posts: 273
Member Since: ‎10-06-2009
Message 4 of 10 (12,066 Views)

Re: System Fan Failure on Pavilion a1730n

[ Edited ]

There should be a sticker on the underside in the center, you should be able to at least get a part # and hopefully the web can provide the specs.

 

HP's P/N is  5188-3722 http://partsurfer.hp.com/Search.aspx?type=PROD&SearchText=RK574AA

 

Can't believe they want $55 for this!! If it turns out to be the fan, you are better off getting after-market ones.

Message Edited by sclui56 on 10-20-2009 10:44 PM
Regents Professor
TheOldMan
Posts: 4,442
Member Since: ‎12-31-2008
Message 5 of 10 (12,041 Views)

Re: System Fan Failure on Pavilion a1730n

Just a note for those of you that are having this problem - It would appear that this issue could be a malfunction of the motherboard.  If you have done the steps as outlined by sclui56 and everything is working ( as is the situation with my computer - same motherboard) all fans are running, then it could be a false warning.  It does not do it every time but enough to cause concern.  I always check by removing the side cover but so far, the fans are running.  I even put another fan in just in case of a failure, no change.

Any other ideas?

{---------- Please click the "Thumbs Up" to say thanks for helping.
Please click "Accept As Solution" if my help has solved your problem. ----------}

This is a user supported forum. I am a volunteer and I do not work for HP.
Top Student
figureguy
Posts: 5
Member Since: ‎04-22-2009
Message 6 of 10 (11,990 Views)

Re: System Fan Failure on Pavilion a1730n

It happened to me again on Friday morning.  Same message, but the case fan was now starting to sound like something was seriously wrong with it.  I was able to find a new 92mm case fan at a local computer store for about $12.  I removed the old fan, and sprayed the heck out of the dust in the case.  I had all wires disconnected, and put the new fan in.  I booted back up, and knock on wood have not seen the message since.  The fan sounds better than it has since I don't know when, so I wonder if this problem was just progressing over time.  I do hope this is not indicative of a problem with the motherboard.  I surely hope it is not.
Grad Student
sclui56
Posts: 273
Member Since: ‎10-06-2009
Message 7 of 10 (11,984 Views)

Re: System Fan Failure on Pavilion a1730n

Let's hope the cheap fix took care of it.
Teacher
DeniseM-Toronto
Posts: 82
Member Since: ‎06-06-2009
Message 8 of 10 (10,838 Views)

Re: System Fan Failure on Pavilion a1730n

I too have gotten the false warning, but only occasionally.

Top Student
carolinablue
Posts: 6
Member Since: ‎07-23-2009
Message 9 of 10 (8,897 Views)

Re: System Fan Failure on Pavilion a1730n

Where can I purchase replacement Internal Fans for my a1730n desktop?  I am getting error message at start up, fan not working.  I want to replace both of them while I am repairing.  I can't get the part through HP......apparently they don't carry these.

Grad Student
gkdiamond
Posts: 216
Member Since: ‎05-07-2009
Message 10 of 10 (8,172 Views)

Re: System Fan Failure on Pavilion a1730n

I started getting the same error on the same model at boot-up. I opened up the case and cleaned the fan even though it was already pretty clean and I reseated the connector to the motherboard, by pulling it off and reconnecting it, this cleans the contacts and makes sure that there is a good connection. But ever 3 or 4 startups I would still get the error message. I took off the side and once again reseated the connection and also the CPU fan connection but I would still get the error message. I can look in one of the air vents on the side and see that the fan is running so every once in a while I would check when I get the error message. I suspected that either the circuitry in the fan or the circuitry on the motherboard might be going bad. After about 2 months or so I started getting the error message everytime I started the computer. About 2 weeks later, I happened to be sitting at my computer  when I heard a kind of click which seemed a bit strange and not normal. I have several sensor programs that I can monitor my computers' temperatures and fan speeds. I opened one of them and saw that the system fan was reading 0 RPM so I looked in the vent and the fan was not turning. I pulled the fan out planning on getting a replacement but I decided to check it first just to be sure that it was bad. I have several of the 12V DC wallwart power supplies and one 9V DC supply. All the 12V supplies measured anywhere from 18V DC to more than double the 12V DC rating. The 9V DC supply measured 15V DC so I used it and as soon as I put power on the fan it started turning. I then measured the voltage at the motherboard fan connection. With one of my meters I wasn't getting a reading after trying several times. Its' leads were a bit large and hard to hold on the motherboard pins without shorting them but I should have gotten a reading if there was anything there. I tried a second meter with small clips that I could attach to the pins. I got a reading of 11.95V so I plugged the fan back in and it worked fine. I mounted the fan back on the case and booted up with no error message. I checked the the fans' RPM with 2 programs and was getting approximately 2125 - 2150 RPM which is more than double the 825 - 850 RPM I was getting before (and thought was normal). Its not a PWM fan (4 pin) nor does this PC use voltage regulation to adjust the fan speed so I'm at a loss as to exactly what happen but it does seem reasonable to assume that the voltage at the motherboard pins must have been less that 12V for some reason. And, although my system fan has been reading 825 RPM for about a year or so, I now seem to remember it reading much higher and sounding louder at one time like it does now. I have not had a problem with the fan since then.

 

A work around if your fan connection on the motherboard goes bad would be to get a molex to 3 pin fan adapter and use one of the spare 12V power connection from the power supply. You can still use your motherboard and PC. 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation