Question
Reply
 
Honor Student
danieladaniela
Posts: 2
Member Since: ‎07-19-2012
Message 1 of 3 (737 Views)
Accepted Solution

p6616 PCI-e USB 3.0 card problems

I have a p6616 and I wanted to install a PCI-e USB 3.0 card, so I bought one. But it does not work. I insert the card, install with most recent drivers from manufacturer website, the device manager says everything works fine, but nothing works, not even mouse. 

Desktop: HP p6616
product code         xj031ea

mobo: MS-7613 (Iona-GL8E) motherboard

card (which I tried in two different PCI-e slots): Y-6119 USB 3.0 PCI-e card with 4 usb 3.0 ports (two ports in the back and two in front panel). Manufacturer http://unitek-products.com/en/ I realize mobo is PCI-e 1.0 but it should work with 2.0 card, actually I specifically picked a 2.0 lest I have problems with 2.1 and of course I realize I won't get the speed of the specs but yet it should work. 

 

The other PCI-e x4 and the mini PCI are unused, while the PCI-e x16 has installed a video card (geforce gts 450). PSU is more than adequate (cooler master silentpro M 850W). There is no overheating problems as I added fans and I monitor temperatures carefully. 

 

I have tried the mouse on these usb 3.0 with low load on the system, with the system only having to deal with keyboard, wi-fi usb (edimax 11n), two HDD and one SSD (but doing nothing), the built-in CD-DVD (idle) and card reader (idle). Even if there were a problem with the mobo handling power or data rate to be dished out, it should not appear under these conditions, regardless of the fact that really it shouldn't be happening. 

 

I never tried the PCI-e slots with other cards since I have the computer (I got it in dec. 2010) but I suppose they work just fine, as the device manager is happy with them and even recognizes the card, which, however, does not work. 

 

BIOS does not appear to have any setting which can be helpful, but perhaps I am overlooking something... I hope. 

I am at my wit's end. 

 

Thank you so much to everyone who can help. 

 

Daniela 

Provost
Big_Dave
Posts: 20,034
Member Since: ‎07-17-2009
Message 2 of 3 (721 Views)

Re: p6616 PCI-e USB 3.0 card problems

Hi Daniela,

 

What is the USB 3.0 driver version?  The card has the VIA chipset so you might try a later driver and a  possible firmware update.

 

The PCI-E card has another connector on it.  I suspect that connector is used for additional card power. I would hook it up.

---------------------------------------------------------------------------------------
HP e9280t, i7-960, 12GB, Vertex 3 120, ATI 4850
HP DV9700, t9300, Nvidia 8600, 4GB, Crucial C300 128GB SSD
HP Photosmart Premium C309G, HP Photosmart 6520
HP Touchpad
Custom i7-4770k, 8GB, Vertex 3 SSD, Samsung EVO SSD, Corsair HX650,GTX 760
Custom i7-3770k, 8GB, Vertex 3 SSD, Samsung EVO SSD, Corsair HX650, GTX 660TI
Windows 7/8 UEFI/Legacy mode, MBR/GPT
Honor Student
danieladaniela
Posts: 2
Member Since: ‎07-19-2012
Message 3 of 3 (703 Views)

Re: p6616 PCI-e USB 3.0 card problems

Thank you a lot Big Dave.
As you say, it wanted to be powered from the small connector ("floppy drive"). Sorry for delayed reply, I was wary of frying everything and double checked with the card manufacturer :smileyhappy:
Thank you a lot
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation