Question
Power supply LED light flashing after power disconnect - PC does not start anymore
Replies (35)
Reply
 
Intern
paulmar
Posts: 4
Member Since: ‎10-04-2011
Message 11 of 36 (8,832 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

My wife's computer has been having the same problem several times. One solution I found that worked before was to unplug the motherboard power cable and the PSU power cable from the back of the PC and then connect the power cable and connect the motherboard power cable while holding down the power button. Scary, to say the least, but it worked, until one day I accidentally flipped the wrong breaker and then spend two hours trying the same fix with no luck and Googling for a solution again. And here is what I found. This is the simplest yet crudest solution. It’s easy and non invasive and it doesn’t matter how tech savvy you are. Take a blow dryer and turn it on to blow air at the back of the power supply for a couple minutes. When you see the light turn green you’re all set. It's worked for me after it worked for a hundred others, maybe more. See the testimonials on this site: http://talk19.wordpress.com/2008/01/13/hp-m7088d-power-supply-led-blinks-green/. It’s a shame that nothing like this appears on any HP site. So don’t waste your money on a new MoBo or PSU. All you need is your wife’s hair drier.

Student
mrjimbo64
Posts: 1
Member Since: ‎10-18-2011
Message 12 of 36 (8,746 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

Thank you for this information. I just had the same situation happen to me and used this technique and it resolved the problem.

 

Student
keltichiro
Posts: 1
Member Since: ‎11-07-2011
Message 13 of 36 (8,545 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

I've been having this same issue, but I haven't found a fix yet. I'm pretty handy with PCs, but this is a strange problem!

 

So my PC wouldnt power up, and the power supply light is flashing green. So I tried un plugging the power from the back and unplugging the cable from the mobo and then reconnecting them as stated earlier. The light is now solid green! woo! but the PC still won't power up...

 

Any ideas?

Intern
paulmar
Posts: 4
Member Since: ‎10-04-2011
Message 14 of 36 (8,540 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

keltichiro, here are some things I would check:

- Make sure the voltage selector is still set to 110V

- The MoBo power cable is plugged in

- There are no noticeable burned, damaged, or leaking components on the MoBo

- The fans should still start

It's strange that your power supply is now working but the PC won't power up. Maybe you have a different problem than others with the same symptoms. Sounds like your MoBo may have really burned out.

Top Student
flookie1
Posts: 8
Member Since: ‎01-05-2012
Message 15 of 36 (8,027 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

you beauty u r a genious m8 thanks so much ill let you no how it goes
Top Student
flookie1
Posts: 8
Member Since: ‎01-05-2012
Message 16 of 36 (8,027 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

great stuff hediezz u have just saved 5 years of stuff now i gotta get it backed up im scared to turn it of now will it keep doing it ive checked the capacitors they look like new concidering its one of the 1st com compaq presario s4500uk desktop hope it dosnt happen again am i best cleaning my mobo up and any other tips on keeping it from doing it again ? cheers hediezz
Top Student
flookie1
Posts: 8
Member Since: ‎01-05-2012
Message 17 of 36 (8,026 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

paulmar you mean point the blow dryer threw the fan into the power supply box with it pluged in while its flashing ?
Student
JARIAS
Posts: 1
Member Since: ‎04-17-2012
Message 18 of 36 (7,271 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

AMAZING! the blow dryer solution worked...

At first I thought you were kidding, but then I tried it since none of the other posted solutions worked; and after like a minute of "hair blowing" my power supply the PC just started.

I have seen hammering nails with rocksor shoes and unscrewing flat heads with table knives, but this tops all of them.

Thank you PAULMAR for this post.

Student
mk1625
Posts: 1
Member Since: ‎07-15-2012
Message 19 of 36 (6,577 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

[ Edited ]

I used the hair dryer twice and it worked both times.

I unplugged the mother board and it worked.

 

BUT, every single time I power down the computer the power supply starts blinking again so I have to go through the process- either unplug MB or use hair dryer again.

 

The power supply is the original- 250Watts.

 

I will upgrade but don't want to if it's not going to solve the problem for good.

 

What should I do?

Student
tourettestricke
Posts: 1
Member Since: ‎12-03-2012
Message 20 of 36 (5,609 Views)

Re: Power supply LED light flashing after power disconnect - PC does not start anymore

don't ask me how, but the hairdryer method worked for me too. strangest **bleep** thing ive ever seen, but IT WORKED! Awesome!

 

so, i had to kill power at the breaker to do some home improvements, and when i turned the power back on, the pc wouldnt start and the light on the power supply would just flash. PANIC! I held the power switch - nothing. unplugged the power supply lines to the motherboard - nothing. all capacitors on the motherboard seemed okay... Now, im getting nervous...

 


Then, I read one thread here that suggested the hairdryer method... couldnt hurt, i thought. After about 10 seconds of blowing out a dustbunny and warming up the components inside the powersupply, the light stopped flashing, and i hit the power button.........still nothing :smileysad:

 

Then, i quickly realized i hadnt reconnected the supply lines to the motherboard. PHEW, still in the game.

 

I reconnected them, hit the power button, and BINGO! I'm back in operation. I'm posting this from the affected comuter, actually...

 

So, THANK YOU - to whoever suggested this method, you saved me a ton of headache and downtime (i use this computer for my screenprinting operation)

 

This is an always on computer, so  i wont worry about if i'll have this issue again, but will salvage another power supply to replace in the future.

 

HAIRDRYER WORKED FOR ME!!!!

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation