Question
Reply
Honor Student
Posts: 2
Member Since: ‎01-25-2010
Message 1 of 3 (1,222 Views)

high CPU usage on Windows 7

I have searched the forums and the internet and even contacted Microsoft customer support but cannot find any help.  I upgraded my Pavillion a6720y from Vista 64-bit to Windows 7 64-bit Home Premium a couple of months ago.  I guess I was the only person that never encountered a problem with Vista so I was expecting a smooth transition to Windows 7.  The problem that I am experiencing with my HP desktop is very high CPU usage after some random period of low usage after it is first turned on.  The CPU usage goes from a few percent to high 80’s to mid 90’s and everything slows down to a crawl.  This random period can go from minutes to days.  Shutting the system completely down works most of the time.   When checking Task Manager, no processes indicate high usage at all with processes running less than a few percentages after an initial spike after starting a program.  When I check “Show processes from all users”, the only high CPU usage is with System Idle Process and nothing else.  I’ve redone the upgrade couple of times and then finally bit the bullet and did a clean install, but nothing helps.  I’ve kept track of the Processes and the Services in Task Manager that are running when it is in low CPU usage and after it goes into high CPU usage and nothing changes.  I’ve tried too many things on my own to mention here, but would appreciate any suggestions anyone might have.  My hardware specs are as follows:

Reply
0
Provost
Posts: 22,461
Member Since: ‎07-17-2009
Message 2 of 3 (1,209 Views)

Re: high CPU usage on Windows 7

Try this article:

http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/b5c79a15-781b-455a-9003-6d3056...

---------------------------------------------------------------------------------------
HP DV9700, t9300, Nvidia 8600, 4GB, Crucial C300 128GB SSD
HP ENVY 17t Touch,i7-5500u,16GB, 256 GB SSD (on loan)
HP Photosmart 6520
HP Touchpad, HP Chromebook 11
Custom i7-4790k,Z-97, 16GB 2400 mhz, Vertex 3 SSD, Plextor M.2 SSD, Samsung EVO SSD, Corsair HX650, GTX 760TI
Windows 7/8 UEFI/Legacy mode, MBR/GPT
Honor Student
Posts: 2
Member Since: ‎01-25-2010
Message 3 of 3 (1,189 Views)

Re: high CPU usage on Windows 7

Thanks Big Dave.  I had already found that, but I did find the solution here on the HP site at ftp://ftp.hp.com/pub/softlib/software11/COL31608/pv-78469-1/sp44620.exe 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation