EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install (9957 Views)
Reply
Honor Student
ibarbaric
Posts: 3
Member Since: ‎04-01-2010
Message 1 of 7 (9,957 Views)

EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install

Hi!

I have installed the following audio drivers on my HP EliteBook 8530p, as offered in download site for my laptop model:

  • ADI SoundMAX AD1984A Audio Driver for Microsoft Windows XP
  • Microsoft Universal Audio Architecture (UAA) Bus Driver for High Definition Audio

However, I am still getting "Found new hardware" message on every startup, and in device manager my Audio Device on High Definition Audio Bus appears in "Other devices" group with yellow question mark, with unknown device type and status "This device is not configured correctly.".

What should I do?

Thanks in advance!

Provost
erico
Posts: 24,709
Member Since: ‎01-07-2009
Message 2 of 7 (9,950 Views)

Re: EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install

Hi,

 


ibarbaric wrote:

Hi!

I have installed the following audio drivers on my HP EliteBook 8530p, as offered in download site for my laptop model:

  • ADI SoundMAX AD1984A Audio Driver for Microsoft Windows XP
  • Microsoft Universal Audio Architecture (UAA) Bus Driver for High Definition Audio

However, I am still getting "Found new hardware" message on every startup, and in device manager my Audio Device on High Definition Audio Bus appears in "Other devices" group with yellow question mark, with unknown device type and status "This device is not configured correctly.".

What should I do?

Thanks in advance!


 

 

Here is a link to the XP drivers page for your PC.. You need to install the Intel ICH9 chipset driver from the page. Look at the CHipset drivers section. The ICH9 Southbridge is what provides the HD audio for the motherboard. Load that driver first and then load the ADI Soundmax Audio driver, which is in the audio section on the drivers web document.

Best regards,
erico 

 





Help others seeking a solution by clicking on the "Accept As Solution" button if my suggestion resolves the issue you were having
****I am a volunteer, I don't work for HP****


Microsoft MVP - Microsoft Windows Expert - Consumer

Honor Student
ibarbaric
Posts: 3
Member Since: ‎04-01-2010
Message 3 of 7 (9,942 Views)

Re: EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install

Hi, Erico,

I did as you wrote and it helped - I am not getting "new hardware" thing any more. However, in device manager my Audio Device on High Definition Audio Bus is still yellow question mark and "The drivers for this device are not installed. (Code 28)" status. Is this normal?

Thanks!

Provost
erico
Posts: 24,709
Member Since: ‎01-07-2009
Message 4 of 7 (9,934 Views)

Re: EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install

No. That is not normal. You aren't getting the "whining" from Windows because you now have the High Definition Audio bus driver installed.

 

Try the following:

right click the device (with the yellow exclamation point) and uninstall it.  Afterwards, right click any device in Device manager and select scan for new hardware.   Don't let Windows install it. Now go to the directory where you have the downloaded ADI driver and right click it and install it as Admin.

 

Please post your results.

Best regards,
erico





Help others seeking a solution by clicking on the "Accept As Solution" button if my suggestion resolves the issue you were having
****I am a volunteer, I don't work for HP****


Microsoft MVP - Microsoft Windows Expert - Consumer

Honor Student
ibarbaric
Posts: 3
Member Since: ‎04-01-2010
Message 5 of 7 (9,851 Views)

Re: EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install

Hi, Erico,

I tried as you wrote, but nothing changes. I am trying also with "Kudos!" star, but nothing happenes.

Thanks again for your effort!

KR,

Igor

Honor Student
pentaquasar
Posts: 2
Member Since: ‎04-23-2010
Message 6 of 7 (9,635 Views)

Re: EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install

I have almost the same problem, i can t find audio device on High Definition Audio Bus for my pavilion t3325.ch, and i know i need it because the sound doesn' t work and i had it before i intelled windows xp afre a crash..could you send me a link for it please?

Student
KimmySuey
Posts: 1
Member Since: ‎03-31-2011
Message 7 of 7 (6,102 Views)

Re: EliteBook 8530p - Audio Device on High Definition Audio Bus not configured after driver install

Did anyone come up with a solution to this issue?  It's a year later and I'm having the same issue...

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation