Post new question
Question
Reply
 
Honor Student
Posts: 2
Member Since: ‎07-15-2009
Message 1 of 8 (46,271 Views)

No sound after plugging in HDMI monitor?

Just bought a new DV7 and plugged in HDMI monitor to the HDMI port on the laptop. When it is connected, I get no sound. When I disconnect it, I get sound. After I installed the new service pack, I had sound again, but after I disconnected and reconnected the monitor, again, no sound. What gives? Is there something I need to reset or re-enable on this to hear sound when I have my HDMI monitor attached? I tried rebooting, but that didn't help. The only way I get sound is to unplug the monitor. It is running Vista. I have not altered any files or made any other software changes.
Professor
Posts: 1,250
Member Since: ‎12-05-2008
Message 2 of 8 (46,252 Views)

Re: No sound after plugging in HDMI monitor?

jcnash49,

 

Have you tried changing the audio configuration in the control panel?

 

  1. Reinsert the HDMI cable into the HDMI port on the notebook PC.
  2. After approximately 10 seconds, switch the audio source in the Control Panel:
  3. Click Start , Control Panel, Hardware and Sound and then click Sound.
  4. Select the HDMI audio device, click Set Default and then click OK.

 

 Try that with the monitor connected.

 

wes


I am an HP employee.
Honor Student
Posts: 2
Member Since: ‎07-15-2009
Message 3 of 8 (46,234 Views)

Re: No sound after plugging in HDMI monitor?

Thanks, but what did work before I read your message was just defaulting back to the regular speakers!
Distinguished Professor
Posts: 2,817
Member Since: ‎11-21-2008
Message 4 of 8 (46,210 Views)

Re: No sound after plugging in HDMI monitor?

Have try installing the latest driver update for your sound?
______

Pavilion DV2922TX, XP-SP3 32bit, Intel T5750 2.0Ghz, Nvidia Geforce 8400M GS with 128MB, 4GB 667 DDR2, 250GB HDD
Student
Posts: 1
Member Since: ‎03-29-2012
Message 5 of 8 (43,192 Views)

Re: No sound after plugging in HDMI monitor?

Hi, I went under the control panel to try and switch my sound system from my laptop to my monitor like you said, but it is not recognizing my monitor for some reason. I cannot find the device anywhere actually but when I plug in the hdmi my screen pops up on the monitor so I am not sure what to do now.

Intern
Posts: 32
Member Since: ‎04-15-2010
Message 6 of 8 (43,183 Views)

Re: No sound after plugging in HDMI monitor?

hello if you have ati graphics, download this driver Realtek HD Audio Driver R2.67 it has to work. 

Honor Student
Posts: 2
Member Since: ‎12-09-2014
Message 7 of 8 (10,814 Views)

Re: No sound after plugging in HDMI monitor?

Worked lik a charm.  Thank you!

Moderator
Posts: 3,682
Member Since: ‎07-08-2015
Message 8 of 8 (10,803 Views)

Re: No sound after plugging in HDMI monitor?

Hi!

I have closed this thread to help keep the comments timely. If you have more to add, please start a new thread. Click here if you want to learn more about how to start a new conversation/thread.

It may also be helpful if you posted a few more details about your computer/printer and your issues.

1. Product Name and Number (please do not post Serial Number)
• Example: HP Pavilion DV2-1209AX or HP Deskjet 3000 Printer CH393A
2. Operating System installed (if applicable)
• Example: Windows XP, Windows Vista 32-bit, Windows 7 64-bit
3. Error message (if any)
• Example: ""Low disk space"" error in Windows
4. Any changes made to your system before the issue occurred
• Examples: Upgrading your Operating System or installing a new software; or installing new hardware like a printer, modem, or router.

If you have any other questions about forum posting, please feel free to send me a private message!

Thank you!"

I work on behalf of HP. I am a Moderator on the HP Support Forums.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation