Messed up colors (708 Views)
Reply
Honor Student
okunamatata
Posts: 2
Member Since: ‎10-15-2011
Message 1 of 3 (708 Views)

Messed up colors

Hello there! As most of folk I've got a problem.


I have a HP Pavilion dv6420en laptop designed for vista which was running windows 7 for quite a while.
All was good until I reinstalled windows 7 today. It booted up properly and the display was working all good when after like 5 minutes the colors suddenly got messed up. I ran windows driver update, downloaded the newest drivers from NVIDIA webside, tried using vista drivers from HP website in compatibility mode with no success. I also reinstalled windows twice after that but that didn't help either. The weirdest part is that the colors are messed up from the POST screen. I hope it's a problem with nvidia drivers and not the graphics card.. I also tried doing a screenshot but when I opened the file on my other laptop the colors showed up just fine.

any help would be appreciated!

 

P.S. attached a pic of what I'm dealing with.

15102011.jpg


Regents Professor
Kalt
Posts: 3,448
Member Since: ‎11-19-2008
Message 2 of 3 (702 Views)

Re: Messed up colors

If you're seeing a display issue (colors) in the BIOS or during the POST process then it's most likely a hardware failure.  You might first try updating the BIOS.  Try connecting an external monitor to see if the colors look normal on it.  If the colors look normal with the external monitor then it's the LCD or LCD cable that's experiencing a problem.  If the problem occurs on the external monitor then it's the graphics processor (GPU).

Honor Student
okunamatata
Posts: 2
Member Since: ‎10-15-2011
Message 3 of 3 (688 Views)

Re: Messed up colors

can this issue be connected with the fact that I flashed BIOS as well before the colors messed up?

 

I've just tried installing a few earlier versions of BIOS but that doesn't help. I don't recall what was the default BIOS version installed though..

 

Also the BIOS I have on the laptop doesn't have any video settings I could change.. I thought there ought to be something like "use ega/vga" setting but there isn't one..

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation