Question
Reply
 
Teacher
WaliN
Posts: 131
Member Since: ‎06-08-2009
Message 1 of 14 (2,086 Views)

Added Memory to Laptop and Still Runs Slow

I added 4G of memory to my laptop and it still runs slow. I now have a total of 6G of memory.

After the memory upgrade my system is slow with multiple applications being open. Often my memory and processor reaches 70 - 80% of capacity with only a few applications open. Any thoughts on this?

My system is running windows vista and I have a 2.5Ghz processor.
PhD Student
Knute
Posts: 1,329
Member Since: ‎09-29-2010
Message 2 of 14 (2,066 Views)

Re: Added Memory to Laptop and Still Runs Slow

You got Vista, thats your problem!  What  processes are running in Task Manager when this happens? 

________________________________________________________________________________________________________

  • I Love Kudos! If you feel my post has helped you please click the White Kudos! Star just below my name
  • If you feel my answer has fixed your problem please click 'Mark As Solution' and make it easier for others to find help quickly

  • Intern
    RoadiJeff
    Posts: 41
    Member Since: ‎12-11-2010
    Message 3 of 14 (2,045 Views)

    Re: Added Memory to Laptop and Still Runs Slow

    [ Edited ]

    Do you regularly run any anti spyware utilites?  Several times per month I run Spybot S&D and SUPERAntispyware.  The basic versions are free and work well.  Whenever a relative of mine says that her PC is running slow I go over there, run those two utilities plus disk cleanup and then disk defrag after everything else and it speeds things up.

     

     

     

    Teacher
    WaliN
    Posts: 131
    Member Since: ‎06-08-2009
    Message 4 of 14 (2,031 Views)

    Re: Added Memory to Laptop and Still Runs Slow

    I also did a memory upgrade on my system that runs XP and did not see a significant improvement in performance.

     

    I noticed most of the time the memory and processor goes to capacity when using IE and Powerpoint. Sometimes after closing Powerpoint, I find it still running in the task manager and I have to manually end task.

     

    As for a virus scan, I use McAfee and no virus alerts popped up, so I am not sure if having a virus is the issue.

     

    Is there a setting in my system to improve the performance and optimize the use of my added memory?

    Intern
    RoadiJeff
    Posts: 41
    Member Since: ‎12-11-2010
    Message 5 of 14 (2,001 Views)

    Re: Added Memory to Laptop and Still Runs Slow

    McAfee antivirus will not keep things like spyware from getting in your system. Viruses and spyware are two different things. I run Avast antivirus but I still run regular scans with the two anti spyware utilities that I mentioned in my previous message.
    Teacher
    WaliN
    Posts: 131
    Member Since: ‎06-08-2009
    Message 6 of 14 (1,981 Views)

    Re: Added Memory to Laptop and Still Runs Slow

    I am running McAfee with AntiSpyware and my latest scan only removed cookies, but no virus. I am not sure if the cookies was slowing my system down. Any other suggestions?

    Regents Professor
    pepe999
    Posts: 3,726
    Member Since: ‎03-09-2010
    Message 7 of 14 (1,978 Views)

    Re: Added Memory to Laptop and Still Runs Slow

     


    WaliN wrote:
    I added 4G of memory to my laptop and it still runs slow. I now have a total of 6G of memory.

    After the memory upgrade my system is slow with multiple applications being open. Often my memory and processor reaches 70 - 80% of capacity with only a few applications open. Any thoughts on this?

    My system is running windows vista and I have a 2.5Ghz processor.

    Could you tell us what type of memory you have added and what type of memory has been in the laptop already, please?

     

    Dv6-7000 /Full HD/Core i5-3360M/GF 650M/Corsair 8GB/Intel 7260AC/Samsung Pro 256GB
    HP Touchpad provided by HP
    Currently on Debian Wheeze

    *Please, help other users with the same issue by marking your solved topics as "Accept as Solution"*
    Honor Student
    Andrew_315
    Posts: 2
    Member Since: ‎01-11-2011
    Message 8 of 14 (1,951 Views)

    Re: Added Memory to Laptop and Still Runs Slow

    Speed is not only determined by how much RAM you have. You can gain speed by either 1)faster processor 2)data transfer rate of your HDD and third and least likely to create much of a difference, RAM.

    Teacher
    WaliN
    Posts: 131
    Member Since: ‎06-08-2009
    Message 9 of 14 (1,947 Views)

    Re: Added Memory to Laptop and Still Runs Slow


    pepe999 wrote:

     


    WaliN wrote:
    I added 4G of memory to my laptop and it still runs slow. I now have a total of 6G of memory.

    After the memory upgrade my system is slow with multiple applications being open. Often my memory and processor reaches 70 - 80% of capacity with only a few applications open. Any thoughts on this?

    My system is running windows vista and I have a 2.5Ghz processor.

    Could you tell us what type of memory you have added and what type of memory has been in the laptop already, please?

     


    My system came with a 2G DDR PC2-6400 memory and I installed a 4G DDR PC2-6400 in the extra memory slot.

    Regents Professor
    pepe999
    Posts: 3,726
    Member Since: ‎03-09-2010
    Message 10 of 14 (1,918 Views)

    Re: Added Memory to Laptop and Still Runs Slow

    Try it without the 2GB memory module first. It might cause troubles when you have 2 modules with a different capacity...

    Dv6-7000 /Full HD/Core i5-3360M/GF 650M/Corsair 8GB/Intel 7260AC/Samsung Pro 256GB
    HP Touchpad provided by HP
    Currently on Debian Wheeze

    *Please, help other users with the same issue by marking your solved topics as "Accept as Solution"*
    † The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation