Question
Reply
 
Student
TheLoneWolfling
Posts: 1
Member Since: ‎08-08-2012
Message 1 of 1 (361 Views)

HP G60-120CA Replacement battery not charging/discharging

I have an HP G60-120CA laptop, running Windows Vista x64. It's worked reasonably well, aside from a few issues over the years (the original charger died and I've had to clean the fan of dust and re-thermal paste the heat sink a couple of times. All in all, a pretty good track record.). However, I recently decided to replace the battery, as the old one was on its last legs (~20 minutes battery life) and I am going to university in the fall. So I got a new battery. The old battery said to replace with hp spare 498482-001, so I did. And then the weirdness started.

 

I put the new battery in this morning. It reported an initial charge of 60,145mWh (97,697mWh capacity) (61.6% charge.) And then it sat there. Windows reports "plugged in, charging", but the charge hasn't changed at all, and BatteryBar reports a charge rate of 0mW.

 

When I unplugged the laptop, it went dead exactly as if there was no battery in the laptop. I rebooted it with the power cable in again, and the charge level was exactly the same as before. However, HP Battery Check reports the battery is good.

 

I've tried replacing the battery / un/re/plugging the power cord in various combinations while the laptop was off, but no dice. If I try to turn on the laptop with the battery in and the power cord unplugged, it does nothing, not even flash the battery LED to report low battery.

 

Oh, and the old battery, with the exception of the fact that it is aging, charges and discharges just fine.

 

Any suggestions? (I'm going to leave it plugged in / off overnight to see if it fixes itself on its own, but I'm doubtful as to if it will work.)

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation