Question
Reply
 
Top Student
FlyboyData
Posts: 8
Member Since: ‎07-02-2010
Message 1 of 1 (2,324 Views)

Presario CQ56-115DX: Buggy BIOS upgrade?

Hi, got a brand new Compaq CQ56 here, running Windows 7 Pro 64 bit edition (upgraded from the factory Windows 7 Home Premium build that the computer came with).

 

I downloaded the BIOS update, version F.05A, SP50336, for the system, and tried to apply it.

 

I got the goofy little crayon dude window, that apparently writes something to the BIOS's flash memory (side note: c'mon HP.  Can't you make the vendors tools look more professional than that?).  When it was done, it automagically rebooted the computer.

 

Upon reboot, I got a BIOS notification that a new BIOS version is ready to be installed, and press ENTER to continue, or ESC to delay it for another time.

 

After pressing enter, everything seems to go fine, except that after reaching 100% on verifying the new BIOS image, the system apparently hangs, with the CPU fan turning full tilt (I can hear it, and feel lots of heat being blown off).  I have given it up to 20 minutes to complete, to no avail.  The system is totally hung.  The only way to get it to boot again is to remove the power and the battery.  Rebooting and going through with the BIOS upgrade results in the same thing.

 

Pressing ESC (to avoid the reflash BIOS process) results in a normal boot up.

 

Is anyone at HP aware of this apparent bug?

 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation