Question
Reply
 
Honor Student
LovelessFiend
Posts: 2
Member Since: ‎06-26-2010
Message 1 of 9 (14,775 Views)

no ide device detected

recently my hp dv9812us crashed and won't seem to work

when i turn it on and it loads up and no operating system would appear

i used the bios hard drive test and it just says no ide device detected

i took it out and connected using a usb to my other pc and i can access the drive

i put it in the secondary slot and it would show up in the bios

 

so i'm wondering wat could be wrong with it here?

someone help plzz and thank you

Provost
CherylG
Posts: 21,499
Member Since: ‎11-12-2008
Message 2 of 9 (14,736 Views)

Re: no ide device detected

[ Edited ]

Have you tried reinstalling it in the laptop? Sometimes a loose connection can cause the problem. It could also be bad, not bad enough that it won't show up as a secondary drive but too bad to boot an OS from. If that is the case, you will have to replace it and boot from your Recovery Disk set to reinstall Windows.

 


******Clicking the Thumbs-Up button is a way to give Kudo's -Thanks!.******
**Click Accept as Solution on a Reply that solves your issue to help others who are searching**
Intern
tieronetech
Posts: 40
Member Since: ‎04-20-2010
Message 3 of 9 (14,728 Views)

Re: no ide device detected

I agree with Cheryl, try to reinstall it and see if the connection was loose. If still no luck, plug it back in to your USB adapter  into the other computer and copy a large file back and forth, like a movie, or a bunch of files. I want to know if it fails after a short time, a possible bad hard drive. The hard drive could have an issue that will prevent it from booting an OS but still be usable as a storage device. Run checkdisk or a similar program on it.

Double check your BiOS setting and back sure that something did not get that messed up. If you are unsure, you can reset the BiOS back to factory settings.

Honor Student
LovelessFiend
Posts: 2
Member Since: ‎06-26-2010
Message 4 of 9 (14,716 Views)

Re: no ide device detected

i have try removing and reinstalling it back into the primary hard drive slot it just won't show up

in the secondary slot it shows up so i ran a hard drive test from the bios and it passed the test so i'm thinking the hard drive should be fine

so it might be the connection on the motherboard that might be the problem

i sadly misplaced my Recovery Disk so that won't be a option for me until i could find them

 

Intern
tieronetech
Posts: 40
Member Since: ‎04-20-2010
Message 5 of 9 (14,706 Views)

Re: no ide device detected

I am curious - what exactly are you describing as the primary hard drive slot and the secondary slot? 

The info I can find lists this unit as having a single 250g hard drive, 3g RAM and a lightscribe optical drive with Vista or XP.

 

There should be a cover on the back with usually 2 screws that covers the hard drive since this is a 17 inch unit. Any chance you could take a picture and post it to flickr.com or filefront.com or photobucket.com so I can see what you are looking at, the locations of the primary and secondary slots? I can only see a listing for a single hard drive in this model.

 

Thanks!

Honor Student
2good2go
Posts: 1
Member Since: ‎07-25-2010
Message 6 of 9 (14,585 Views)

Re: no ide device detected

Had the same issue: After display of  "Operating System Not Found", wnet into bios to check hdd and got "No IDE Device."

 

Sloved it by holding control alt escape while booting.

 

Now I'm 2good2go.

 

Good Luck!

Student
nj364
Posts: 1
Member Since: ‎11-24-2012
Message 7 of 9 (8,371 Views)

Re: no ide device detected

I have tried everything and i cant fix it everything i try just doest work
Student
scumie
Posts: 1
Member Since: ‎01-16-2013
Message 8 of 9 (7,755 Views)

Re: no ide device detected

I'm having the same issue, probably same model. I found others with the same problem and all seems related. 

 

see: http://www.tomshardware.com/forum/68039-35-dv9700-primary-disk-drive-recognized#bas

Student
DON_001
Posts: 1
Member Since: ‎03-28-2013
Message 9 of 9 (6,507 Views)

Re: no ide device detected

Hi Everyone,

 

                         The only solution to this problem is getting an Operating system Re-Installtion.So pick up your phone dial the customer service and order an Operating System CD....Re-install the Operating System and the problem would be fixed.I have tried it many a times and it worked for me.

 

Revert back for any queries or clarifications.

 

Highest Regards,

Vharris Khan

Sr.Technician

#Iwork4Dell.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation