Question
Reply
 
Honor Student
jcnash49
Posts: 2
Member Since: ‎07-15-2009
Message 1 of 6 (24,840 Views)

No sound after plugging in HDMI monitor?

Just bought a new DV7 and plugged in HDMI monitor to the HDMI port on the laptop. When it is connected, I get no sound. When I disconnect it, I get sound. After I installed the new service pack, I had sound again, but after I disconnected and reconnected the monitor, again, no sound. What gives? Is there something I need to reset or re-enable on this to hear sound when I have my HDMI monitor attached? I tried rebooting, but that didn't help. The only way I get sound is to unplug the monitor. It is running Vista. I have not altered any files or made any other software changes.
Associate Professor
wes_notebooks
Posts: 836
Member Since: ‎12-05-2008
Message 2 of 6 (24,821 Views)

Re: No sound after plugging in HDMI monitor?

jcnash49,

 

Have you tried changing the audio configuration in the control panel?

 

  1. Reinsert the HDMI cable into the HDMI port on the notebook PC.
  2. After approximately 10 seconds, switch the audio source in the Control Panel:
  3. Click Start , Control Panel, Hardware and Sound and then click Sound.
  4. Select the HDMI audio device, click Set Default and then click OK.

 

 Try that with the monitor connected.

 

wes


I am an HP employee.
Honor Student
jcnash49
Posts: 2
Member Since: ‎07-15-2009
Message 3 of 6 (24,803 Views)

Re: No sound after plugging in HDMI monitor?

Thanks, but what did work before I read your message was just defaulting back to the regular speakers!
Distinguished Professor
Rakhmad
Posts: 2,817
Member Since: ‎11-21-2008
Message 4 of 6 (24,779 Views)

Re: No sound after plugging in HDMI monitor?

Have try installing the latest driver update for your sound?
______

Pavilion DV2922TX, XP-SP3 32bit, Intel T5750 2.0Ghz, Nvidia Geforce 8400M GS with 128MB, 4GB 667 DDR2, 250GB HDD
Student
kwhonic
Posts: 1
Member Since: ‎03-29-2012
Message 5 of 6 (21,761 Views)

Re: No sound after plugging in HDMI monitor?

Hi, I went under the control panel to try and switch my sound system from my laptop to my monitor like you said, but it is not recognizing my monitor for some reason. I cannot find the device anywhere actually but when I plug in the hdmi my screen pops up on the monitor so I am not sure what to do now.

Intern
guido_1
Posts: 32
Member Since: ‎04-15-2010
Message 6 of 6 (21,752 Views)

Re: No sound after plugging in HDMI monitor?

hello if you have ati graphics, download this driver Realtek HD Audio Driver R2.67 it has to work. 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation