Question
Reply
 
Honor Student
Ferbert
Posts: 3
Member Since: ‎12-30-2010
Message 1 of 7 (8,037 Views)

Compaq 6910p won't power up

Hi - I have a Compaq 6910p that has worked fine for 2 years.  I powered it off 2 days ago.  I try and power it up now, and it won't do anything.  I have checked the battery from another 6910, removed the extra RAM, re-seated the HD, tried another HD from another 6910, and a different charger - all to no avail.  Any other ideas?  Let me know, and thanks!

 

Greg

Provost
Paul_Tikkanen
Posts: 46,573
Member Since: ‎07-13-2010
Message 2 of 7 (8,029 Views)

Re: Compaq 6910p won't power up

Honor Student
Ferbert
Posts: 3
Member Since: ‎12-30-2010
Message 3 of 7 (8,027 Views)

Re: Compaq 6910p won't power up

But - it won't even go that far.  It never powers up.

 

Greg

Provost
Paul_Tikkanen
Posts: 46,573
Member Since: ‎07-13-2010
Message 4 of 7 (8,022 Views)

Re: Compaq 6910p won't power up

Did you try it? 

 

I had an nc8000 which exhibited similar symptoms as yours. Nothing happened when I hit the power button. I did this and for whatever reason, it came to life and hasn't given me a problem since.

Provost
Paul_Tikkanen
Posts: 46,573
Member Since: ‎07-13-2010
Message 5 of 7 (8,021 Views)

Re: Compaq 6910p won't power up

Also, if that doesn't work, maybe your 6910p is still under warranty?

 

Normally they come with 3 year warranties and that model ran from 2007 - 2008.

 

You can check here and see by entering your complete model number and serial number where indicated:

 

http://h20000.www2.hp.com/bizsupport/TechSupport/WarrantyLookup.jsp?lang=en&cc=us&prodSeriesId=18477...

 

Paul

Honor Student
Ferbert
Posts: 3
Member Since: ‎12-30-2010
Message 6 of 7 (8,007 Views)

Re: Compaq 6910p won't power up

Yep - tried it - nothing.  May be motherboard time....

Student
heymichaelm
Posts: 1
Member Since: ‎03-27-2014
Message 7 of 7 (1,693 Views)

Re: Compaq 6910p won't power up

Hello, I have tried the procedure on my 6910p and it worked but I find that I have to do it the next time as well.  Is there something I could check that might be causing this to repeatedly happen?  Perhaps a user replaceable battery of some sort (guessing here)?  I am using the 90w ac adaptor.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation