Question
Reply
 
Intern
happypouch
Posts: 30
Member Since: ‎04-14-2010
Message 1 of 68 (97,793 Views)
Accepted Solution

SD Card reader not working.

My NC6320 has a card reader at front for SD-MS/PRO.MMC.SM.XD Cards.

 

OS= XP Pro + SP3

 

It appears not to be working when a SD Card is inserted as nothing shows up as a 'removal drive' as if when I insert a flash or external hdd drive into USB.

 

Any tips of what to check for if it's working or of any software or drivers needed. And where to find this in the Devices.

 

thanks

Intern
happypouch
Posts: 30
Member Since: ‎04-14-2010
Message 2 of 68 (97,775 Views)

Digital Media Slot - not working

According to the PDF manual I've found for my NC6320, the slot I've reffered to is known as 'Digital Media Slot'.

 

The manual also says its for selected models only. But how do I know if mine is a selected model to have such a working slot, also mine has a LED alongside to show when a card is inserted.

 

But this shows nothing too.

Provost
Paul_Tikkanen
Posts: 42,268
Member Since: ‎07-13-2010
Message 3 of 68 (97,770 Views)

Re: Digital Media Slot - not working

Hi:

 

I have an nc6400 with the same problem. All drivers loaded. No ? devices. There is an SD controller driver listed in the Device mgr. I insert an SD card, and nothing happens. Once I inserted one and it showed up in my computer but it said it needed to be formatted.

 

I read that some SD cards are not compatible with the SD card readers in our PC's.

 

I have pretty much given up hope that my notebook will read SD cards from that slot. I tried 2 brands. One gave the disk needs to be formatted, and one did absolutely nothing.

 

I guess the only workaround is to plug the camera into one of the USB slots and access the SD card that way.

 

Paul

Provost
Daniel_Potyrala
Posts: 10,921
Member Since: ‎01-31-2009
Message 4 of 68 (97,762 Views)

Re: Digital Media Slot - not working

[ Edited ]

@Paul

 

Hi,

Could you check below solution.

Uninstall your current driver for Texas Card Reader.

Now install Texas Instruments Media Card Reader Driver sp38607 ver 2.0.0.8 A

 

Note:

If there will not be any option for standard uninstalation then download installation file of your current driver and run it.

You should see the proposals to uninstall the driver.

 

** Say thanks by clicking the "Thumb up" icon which is on the left. **

 

** Make it easier for other people to find solutions, by marking my answer with "Accept as Solution" if it solves your issue. **

 

  Microsoft MVP Windows Expert - Consumer
Intern
happypouch
Posts: 30
Member Since: ‎04-14-2010
Message 5 of 68 (97,749 Views)

Re: Digital Media Slot - not working

Hi Paul,

 

Thanks for that it works a treat.

 

Thanks again

 

Tel

Provost
Daniel_Potyrala
Posts: 10,921
Member Since: ‎01-31-2009
Message 6 of 68 (97,743 Views)

Re: Digital Media Slot - not working

 


happypouch wrote:

Hi Paul,

 

Thanks for that it works a treat.

 

Thanks again


Sorry for dumb question.

Is my solution working for you or you just telling thanks to Paul for his reply?

I need to confirm this because I'm not sure is this problem solved or not. :smileywink:

 

 

** Say thanks by clicking the "Thumb up" icon which is on the left. **

 

** Make it easier for other people to find solutions, by marking my answer with "Accept as Solution" if it solves your issue. **

 

  Microsoft MVP Windows Expert - Consumer
Provost
Paul_Tikkanen
Posts: 42,268
Member Since: ‎07-13-2010
Message 7 of 68 (97,736 Views)

Re: Digital Media Slot - not working

Hi, Daniel:

 

I'll try it on my nc6400 tonight & let you know one way or the other. I am at work right now.

 

BTW, I am running W7 x64 on my nc6400.

 

Paul

Intern
happypouch
Posts: 30
Member Since: ‎04-14-2010
Message 8 of 68 (97,731 Views)

Re: Digital Media Slot - not working

Hi Daniel

 

Sorry, I replied to your reply using the name '@Paul' thinking thats the name to answer to.

 

 

Yes as you suggested uninstalling and downloading the driver from the link, works fine.

 

I had downloaded SP32017 and SP33416 without any joy.

 

Sorry for the mixup, Thanks again

 

Tel

Provost
Paul_Tikkanen
Posts: 42,268
Member Since: ‎07-13-2010
Message 9 of 68 (97,717 Views)

Re: Digital Media Slot - not working

Hi, Daniel:

 

Well, unfortunately that driver didn't work for me. My 2 cards do the same thing. One asks to be formatted and one doesn't do a thing.

 

I would have to assume the card reader has an issue.

 

But your solution fixed one person's issue. I never use the card reader anyway. I just like to know that everything on my PC works.

 

Thanks,

 

Paul

Provost
Daniel_Potyrala
Posts: 10,921
Member Since: ‎01-31-2009
Message 10 of 68 (97,706 Views)

Re: Digital Media Slot - not working

[ Edited ]

pjtikkanen wrote:

Well, unfortunately that driver didn't work for me. My 2 cards do the same thing. One asks to be formatted and one doesn't do a thing.

 

I would have to assume the card reader has an issue.


One question. Have you tried to install this driver in XP and Vista compatibility mode?

 

** Say thanks by clicking the "Thumb up" icon which is on the left. **

 

** Make it easier for other people to find solutions, by marking my answer with "Accept as Solution" if it solves your issue. **

 

  Microsoft MVP Windows Expert - Consumer
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation