HP OfficeJet 7410 fails to install (6925 Views)
Reply
Honor Student
ChronosFT
Posts: 3
Member Since: ‎09-15-2009
Message 1 of 5 (6,925 Views)
Accepted Solution

HP OfficeJet 7410 fails to install

I have attempted to install my HP OfficeJet 7410 on two different Vista machines, but I am getting Fatal Error 2203 on both machines with every attempt to install the AIO. I downloaded the lastest set of drivers for the respective 32/64 bit systems, and whether it is 32/64-bit system, HP.com points you to the same named file: AIO_CDB_Full_Network_enu_NB.exe.

 

Both machines have Windows Vista Home Premium with Service Pack 2. One machine, an HP s3307c, has Vista 32-bit installed and the other, a Dell Studio 1537, has Vista 64-bit installed. Besides Service Pack 2, each machine has had every other possible update installed via Windows Update and each machine also has Internet Explorer 8 installed, if this makes any difference.

 

About half-way through each attempt to install the software, I get the same error code "fatal error 2203" but the message will read a little differently each time. There is usually a different end message with "MSI.xxxxxx" causing some unknown problem. The last one was "MSI.Bufferchm".

 

The HP OJ 7410 is on the Vista hardware compatibility list, and I had previously installed the OJ 7410 on each of these machines with no trouble, and I even used the 7410 on both machines with no trouble. The HP desktop was connected via USB and the Dell laptop was connected via wireless. However, the hard drive in my HP s3307c desktop died recently and I had to replace it. In the process of reinstalling everything I have run into this roadblock with the 7410. I didn't have to reload Vista on the Dell Studio 1537, but about 3-4 months before the HP desktop died the Dell laptop stopped communicating wirelessly with the OJ 7410, so I took the opportunity to reload both machines.

 

I even followed the proposed solutions on the following web page, but I have had no luck with a successful installation:

http://h10025.www1.hp.com/ewfrf/wc/document?lc=en&dlc=en&cc=us&docname=c00459898

 

I could really use some help here. I have never had such difficulty installing a piece of HP hardware, especially something like a printer/scanner (in this case an AIO). It makes no sense to me that I could install this AIO before and have it working to just suddenly no complete an install on the same machines with the same operating systems. It also makes no sense to me that HP just posted updated files this month and none of them work.

 

Help!

 

PhD Student
Binary_Zen
Posts: 821
Member Since: ‎08-12-2009
Message 2 of 5 (6,894 Views)

Re: HP OfficeJet 7410 fails to install

Try the steps below and let us know if it resolved your issue. I got it from an Error 2203 document from microsoft.com (http://support.microsoft.com/kb/2000547)

 

 

*Add the Everyone group with Full Control permissions to the Permissions list of the default temporary files folder:

  1. Click the Windows menu button (formerly the Start button) or press the Windows button on the keyboard.
  2. In the Start Search box type %temp% and then click the Temp folder item that appears at the top. 
  3. At the top of the Explorer window, in the address bar, click the folder to the left of Temp in the folder path (Local by default).
  4. In the folder list, right-click the Temp folder and then click Properties and then click the Security tab.
  5. Click the Edit... button and on the next screen click Add.
  6. On the next screen, in the large text window type Everyone and then click Check Names - Everyone should then be underlined.
  7. Check the box for Full control under the Allow column, and then click OK, then OK again, and OK again to close all the windows.
Binary_Zen (worked at HP )

Click the white Kudos star to say thanks
Please mark Accept As Solution if it solves your problem
Honor Student
ChronosFT
Posts: 3
Member Since: ‎09-15-2009
Message 3 of 5 (6,804 Views)

Re: HP OfficeJet 7410 fails to install

Before I came back here to see if there were any replies, I tried to use the original installation disk that came with the printer. I couldn't install using the original disk because the installation program insisted that my profile (the only one registered on the computer) did not have Admin privileges. However, in the list of user accounts it shows only my account, and it shows my account has admin privileges.  So, I gave up that attempt and came back here.

 

Binary_Zen, I followed the instructions listed in your reply and when I was in the Permissions for Temp window, I clicked on okay, waited a moment and next received an Error Applying Security warning:

 

"An error occurred while applying security information to:

 

C:\Users\Dave\AppData\Local\Temp\hsperfdata_Dave

 

Access is denied.

 

    | Continue |    |  Cancel  | 

 

I clicked on ok and the program continued without further warnings or errors, I then clicked on the final OK.

 

Next, I mistakenly returned to running the Setup.exe from the original disk (a mistake after a very long day), and the Administrator problem went away, but I still got a warning message about the OS (Vista instead of the expected XP). Next, I received an error that E:\Setup\hpzprl01.exe -m preloadproductdrivers  -ll enu,esn,fra,ptb,enu,ell,plk ...  X The system cannot find the file specified. OK.  Anyway, I cleaned up that mess by answering positively to the installation offer to undo any changes made while attempting to install the software. After the computer restarted, I went back to the Temp folder to verify that the Everyone permissions were still there -- they were.

 

I started up the current software installation from HP (the one I initially complained about). I also remembered to uncheck every option except the printer and scanner drivers, as well as the OCR reader. I read that the other options are not compatible with Vista -- they are mostly crapware anyway. And, finally, SUCCESS!  The printer feature has been installed and prints a test page successfully! Also, I scanned the test print into Paint with success!

 

Again, thank you very much!

 

 

 

 

 

 

Honor Student
ChronosFT
Posts: 3
Member Since: ‎09-15-2009
Message 4 of 5 (6,753 Views)

Re: HP OfficeJet 7410 fails to install

New troubles ...

 

I have attempted to follow the same set of instructions for getting AIO_CDB_Full_Network_enu_NB.exe to install on my Dell Studio 1537 laptop that runs Windows Vista 64-bit. However, I am getting errors that are like the ones I received originally from my desktop computer that runs Windows Vista 32-bit. Just like the desktop, the laptop arrives to the point where you connect the HP OJ 7410 and it recognizes the AIO easily. Once I click Next to confirm that it has detected the correct device, about 30-40 seconds later I get a popup error message that offers a Details button. Clicking on Details reveals this: 




Error Situation Code: 30058368

The following lines were retrieved from the installation error logs.

Now Launching=X:\hpzmsi40.exe -list product -I XXX -f X:\DIVins??.DAT

Error message received: The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2203.

X:\AIO_CDB_ToolboxIni64.msi failed with return code 1603

MSIInstall() failed with 1603 for MSI Toolbox_64

Exit code = 1603

  | OK |

 

 

So, I click on OK and let the installation routine proceed with uninstalling itself (I have no choice). This error occurred when I attempted to setup the AIO using the network. Next, I restart the installation and request that the installation program use the USB setup. After it recognizes the device, I receive this:

 

 

Fatal error during installation.

The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2203.

Please go to http://www.hp.com/support for troubleshooting information about "Fatal Error" and "MSI.BufferChm"

  | OK |


I clicked on okay and once the Details button was available I clicked it and got this:


The following lines were retrieved from the installation error logs.

Now Launching=X:\hpzmsi40.exe -list product -I XXX -f X:\DIVins??.DAT

Error message received: The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2203.

X:\BufferChm.msi failed with return code 1603

MSIInstall() failed with 1603 for MSI BufferChm

Exit code=1603

Both computers are setup identically as far as user names, passwords (not that the installation routine requests them). Perhaps the solution was only valid for a 32-bit installation of Vista?

 

Any help you can provide would be appreciated.

 

Thanks,

Chronos

 

 

Student
never12die
Posts: 1
Member Since: ‎09-22-2010
Message 5 of 5 (4,264 Views)

Re: HP OfficeJet 7410 fails to install

Change your "language for non-unicode programs" in control panel to English.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation