Question
Reply
 
Honor Student
dinahlee
Posts: 3
Member Since: ‎03-12-2012
Message 1 of 6 (191 Views)

HP 8500 not found if connected via hub

I have an Officejet Pro 8500 all-in-one which works just fine if it's connected directly to the PC (in this case, a fairly new Dell desktop running Windows 7 Home Premium). But if I try to connect the printer via a hub (a powered one), the computer doesn't find it. Does anyone know if this is an issue with the printer or with the PC itself? And in either case, is there a solution?

 

And on another topic entirely, since there are so many giant-brained experts out there, do any of you know what the maximum operable length is for a USB cable? Thirty feet? Forty? I mean just one cable, not a daisy chain. They do come in those lengths, but before I buy one, I'd like to have at least some idea if it will work.

 

Thanks a million on both counts!!

Regents Professor
8lives
Posts: 4,915
Member Since: ‎12-02-2008
Message 2 of 6 (182 Views)

Re: HP 8500 not found if connected via hub

Is that a USB hub?

I would not go beyond 10 ft. (Max is about 16 ft)



--------------------------------------------------------------------------------
Please mark the post that solves your issue as "Accept as Solution".
Click the “Kudos Thumbs Up" on the left to say “Thanks”!
I am not a HP employee.
Honor Student
dinahlee
Posts: 3
Member Since: ‎03-12-2012
Message 3 of 6 (180 Views)

Re: HP 8500 not found if connected via hub

Yes, it's a Belkin hub with its own power supply. Does that help??

Regents Professor
8lives
Posts: 4,915
Member Since: ‎12-02-2008
Message 4 of 6 (178 Views)

Re: HP 8500 not found if connected via hub

What is the model # of the Belkin?

Is there any reason why you can not use a wired network connection?



--------------------------------------------------------------------------------
Please mark the post that solves your issue as "Accept as Solution".
Click the “Kudos Thumbs Up" on the left to say “Thanks”!
I am not a HP employee.
Honor Student
dinahlee
Posts: 3
Member Since: ‎03-12-2012
Message 5 of 6 (176 Views)

Re: HP 8500 not found if connected via hub

Back of the thing says: Belkin hi-speed USB 2.0 7-port hub - FSU 237, rev. 3. Now you know everything.

 

Originally there was no problem with a wired connection - that was what I did for months. But now the computer's on the other side of the room from the printer, and I'd like to be able to keep it there, along with a few other peripherals (external HDs, etc.), all hitched up to the aforementioned hub or something similar (hence the loooooong USB cable). And of course there's the intellectual puzzle aspect of the whole thing...why doesn't this work, and how can I fix it?

 

Any suggestions gladly considered. Thanks.

Regents Professor
8lives
Posts: 4,915
Member Since: ‎12-02-2008
Message 6 of 6 (173 Views)

Re: HP 8500 not found if connected via hub

How many of the F5U237 ports are you using?

It would be much easier to connect the 8500 to your router!



--------------------------------------------------------------------------------
Please mark the post that solves your issue as "Accept as Solution".
Click the “Kudos Thumbs Up" on the left to say “Thanks”!
I am not a HP employee.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation