Question
Reply
 
Honor Student
upsfeeder88
Posts: 2
Member Since: ‎07-05-2009
Message 1 of 3 (2,530 Views)

HP Laptops won't recognize Belkin Wireless-G Router

I have problems with the wireless connectivity of my three laptops. Two are HP and one that works is an Acer. I am having a problem with the two HP's. When I turn them on and try to connect to the network, they do not recognize my new network. I have restarted and rebooted the router, I have set a new security password and wireless network, but the HP's recognize my neighbors secured Linksys, and my other neighbors unsecure network(both with poor signal strength) but doesn't recognize mine. Yet when I connect to my Acer laptop, it recognized the network, I signed in and entered my password and now my Acer is fine, yet both my HP laptops, nothing. Rebooting, restarting, updating drivers, reconfiguring, nothing seems to work. Just a note, the HP's were working fine, till I had to reset, reboot, reconfigure my router. Any idea's???????????
Associate Professor
Wi-Fi-Guy
Posts: 1,537
Member Since: ‎11-17-2008
Message 2 of 3 (2,526 Views)

Re: HP Laptops won't recognize Belkin Wireless-G Router

Some Belkin 802.11g wireless-routers implemented a "turbo" or "108 Mbps" mode that is not compatible with the 802.11g standard.  Check to see if anything like this is enabled on your Belkin and if so, turn it off.
Regards / Jim B / Wireless Enthusiasts
( While I'm an embedded wireless systems engineer at work, on this forum I do not represent my former employer, Hewlett-Packard, or my current employer, Microsoft )
+ Click the White Kudos star on the left as a way to say "thank you" for helpful posts.
Honor Student
upsfeeder88
Posts: 2
Member Since: ‎07-05-2009
Message 3 of 3 (2,507 Views)

Re: HP Laptops won't recognize Belkin Wireless-G Router

Thanks for the quick reply. I have the Belkin F5D7230-4 Router. I don't see anything like that in any of the Belkin Tech pages that I looked at. The problem is, both these Laptops were recognizing the belkin for over a year now. We had a thunderstorm the other day, and all of a sudden the router had to be reset. When I did that without the security, the HP's recognized it, but it would drop the signal. Then I would have to reboot again. I added the security, and it doesn't even recognize the router now. I also found out with my son that his Wii and PS3 also aren't recognizing the router. For the time being, I have contacted Belkin to send me a new one. i will see if thats the problem. Thanks again.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation