Question
HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond
Replies (39)
Reply
 
Tutor
JustSomeGuyUKno
Posts: 19
Member Since: ‎03-05-2014
Message 11 of 40 (1,361 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

 

Okay, will do.  

 

I'm also going to call Tech Support about this.  

 

While I'm doing these things, I have a question for you, if I may…

 

•  Must Java be installed or JavaScript be enabled (or both) on the client computer that is attempting to access the EWS?

 

Thanks for your on-going interest.  I'll keep you updated as to my progress.

Tutor
JustSomeGuyUKno
Posts: 19
Member Since: ‎03-05-2014
Message 12 of 40 (1,355 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

 

Well, I…

 

• …completely uninstalled all HP printing software: HP Utility, Firmware Updater, SetUp Assistant, System Preferences print drivers, and anything else I could find on my own.

• …went to the 7520's support page, found the latest drivers and software, and downloaded them.

• …performed a "semi-full reset" on the 7520 (using the keypad code given to me by Tech Support a week or so ago).

• …installed the software according to instructions. 

• …restarted the printer.

• …connected the printer wirelessly, according to instructions (it automatically found the … .10 address you specified).

• …ran the firmware updater (no firmware updates found).

• …installed the software.

• …ran the Set-up Assistant, which 1) described to me how to add the printer driver to System Preferences, and 2) told me that set up was successful.  

• …printed text from a web page (successfully) to make sure I am connected to the printer.

• …opened Safari, typed in http://192.168.1.10/ and hit return, and…

 

FAIL.  

 

Calling Tech Support now.

 

I should add that when I touch on the "Scan" button on the 7520 and then touch on the "Computer" button, it can't find any scan hosts.  But when I open the HP Scan app or Scan from the System Preferences Driver, I can scan images.  

Tutor
JustSomeGuyUKno
Posts: 19
Member Since: ‎03-05-2014
Message 13 of 40 (1,350 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

Worked with HP Tech for about an hour…

He elevated this issue… they will call me back.

Regents Professor
sabretooth04
Posts: 5,731
Member Since: ‎07-30-2012
Message 14 of 40 (1,342 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

Any other computer available???

Say thanks by clicking the Kudos Thumbs Up to the right in the post.
If my post resolved your problem, please mark it as an Accepted Solution ...
I worked for HP but now I'm retired!
Honor Student
Bornsplace
Posts: 4
Member Since: ‎03-27-2014
Message 15 of 40 (1,303 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

[ Edited ]

Same problem over here! Whatever I try, I can't get connection with te EWS from this printer.

I've tried differtent browser, computers, routers,...

I think there must be something wrong with the webserver.

 

anyone?

 

Thnx

Tutor
JustSomeGuyUKno
Posts: 19
Member Since: ‎03-05-2014
Message 16 of 40 (1,290 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

 

Sabre…

 

Sorry to be so long in responding.  No PCs… just an all Apple shop here.  

 

More when (and if) I hear from HP…

 

SomeGuy

Tutor
JustSomeGuyUKno
Posts: 19
Member Since: ‎03-05-2014
Message 17 of 40 (1,289 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

 

Bornsplace…

 

Are you on PCs, Macs, Linux machines?  What sort of WiFi hub / router?  How old is your 7520?

 

Thanks in advance for those details.  

 

SomeGuy

Honor Student
Bornsplace
Posts: 4
Member Since: ‎03-27-2014
Message 18 of 40 (1,277 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

Hi SomeGuy,

 

Only PC's on Xp and Windows 7 here.

I've tried with a Cisco WiFi router and an Eminent WiFi router, no result.

Also tried IE8, Firefox, Chrome, no result.

It's only the EWS that I can't connect with. All the other services work fine.

Also pinging to the IP of the printer works.

I've bought the printer on 19/03/2014

 

 

 

I've contacted HP by phone, so they're busy with te problem. They told me that there must be a problem with the programming of the EWS.

 

Did you already got a new printer? and also with the same problem?

 

Greetz

 

Bornsplace

 

 

 

Tutor
JustSomeGuyUKno
Posts: 19
Member Since: ‎03-05-2014
Message 19 of 40 (1,269 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

 

Once again, thanks, Bornsplace.

 

I only tried Apple Extreme and Express WiFi routers, but in different configurations… none worked with EWS.  

Browsers I tried: Safari latest, Opera latest, iCab latest… no joy.

I tried accessing EWS through their "Direct Wireless" connection option, where there is no intermediary network… just the 7520's wireless network host and my laptop or iPhone.  Again no response.  You might want to try Direct Wireless yourself (if you haven't already) just so we all know for certain.  

I also got responses to pings, like you did.  

In one test, I sent the EWS URL with an https prefix… Safari gave me an alert saying that the HP self-signed certificate was invalid (expiration date in 2033 — no CA, I guess).  This says to me that the packets are getting through the network and into at least the first level of intelligence in the 7520… and back, of course.

It's especially gratifying to learn from you that HP said that there must be a problem with the programming of the EWS.  They have not said as much to me (yet).  I trust that means that they are working on the problem and will have a solution soon — perhaps a firmware update? 

As to other history of all this… I bought my printer o/a March 4, 2014.  Discovered the problem the next day, then I took another day to try to chase it down myself.  Went on Tech support chat with them the next day, and we spent about 4 hours (on and off) troubleshooting the network.  The result was that the Tech told me they were going to send me a new 7520.  

The new unit arrived o/a March 14 (took about a week, sent back the old unit on the 17th).  The same problem occurred on it.  After checking everything again to be sure I wasn't making a mistake on my end, I called their Tech Support by phone and they walked me through tests for an hour with no luck.  Then they "elevated" the problem.  Their higher-level tech called me but we missed each other.  He e-mailed me to follow up, and I replied by e-mail, gave him a time when he could call (as he requested).  No response now for two days.  I will try to call them again later today.    

You can see now why I really appreciate your helpful comments!

 

SomeGuy

Honor Student
Bornsplace
Posts: 4
Member Since: ‎03-27-2014
Message 20 of 40 (1,266 Views)

Re: HP Photosmart 7520 e-All-in-One Embedded Web Server (EWS) Does Not Respond

Hi SomeGuy,

 

I've also tried the "Direct Wireless" option, no result.

Also HTTPS with a certificate error response, no result.

 

So io guess that we both have te same problem here. Strange that there is nobody else with this EWS error.

 

Today HP Tech support (Belgium) called me back and told me that the case was elevated. They'll call me back asap if they find a solution for us both. 

So when they call me, I'll get back to you.

 

I've also sent the url of this thread to te person who called me, so lets hope....

 

Greetz,

 

I'll sent the email concversations from HP to you (Sorry but they're in Dutch)

 

Bornsplace

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation