Question
Reply
 
Honor Student
woodee777
Posts: 3
Member Since: ‎05-08-2009
Message 1 of 2 (535 Views)

HP Solution Center Error

I have a HP Officejet Pro L7780 aio. Ever since the last time I reinstalled Windows 7 64 bit I cannot get the HP Solution Center to move past the error screen that pops up preventing the Solution Center from working. Every time I try to open the HP solution Center I get the message "HP Solution Center cannot run because your device installation is not complete." That message stops the Solution Center from allowing me to scan from it. even though  both the USB and network printer are installed & both work fine. It did take numerous uninstalls (with using the level 3 bat file) and reinstalling the latest software from the HP website before I was finally able to successfully install the usb printer (the "Virtual USB Printer Port" did not show up until I went as far back as possible with a system restore. I have run repairs on the .msi for the Solution Center and on almost all the other .msi components in the set up folder. I have also updated all the printer/scanner drivers I could find in the device manager without any of that fixing the Solution Center. I am able to scan from the panel to a usb stick plugged in to the usb port on the aio. I am missing some scanning options and the overall convenience of using the Solution Center with it stuck on that error messages. I have software from older Sais's that have the old HP Director I was thinking of installing to see if the HP Director would be a work around for the Solution Center, but thought I would ask if anyone out there has ever fixed a similar problem with the HP Solution Center. Thank you in advance for any suggestions...

Tutor
dagrace
Posts: 13
Member Since: ‎09-24-2013
Message 2 of 2 (95 Views)

Re: HP Solution Center Error

I am getting a very similar error. It's with a 6500 aio (E709n), wireless connection. The error says "Solution Center cannot run because your device installation is not complete. Please plug in the USB cable or re-run the setup program for a network installation." I've done that several times. It sees the printer. But it fails (big red X) when I try to continue/update the installation. 

 

I uninstalled everything. Then I ran the scrubber_14 2 or 3 times. Then I reinstalled the software and the printer. I can print (again). But when I run solution center, I get the same error.

 

Help.

 

Thanks.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation