HP Officejet 6500 e709a Series "HP Imaging Device not Found" (7002 Views)
Reply
Student
jasonschatz
Posts: 1
Registered: ‎02-15-2010
Message 1 of 8 (7,002 Views)

HP Officejet 6500 e709a Series "HP Imaging Device not Found"

I have reinstalled the full software, from the CD and from the HP Site. Each time I get the same result when trying to scan from HP solution center: HP Imaging Device not Found, with the extended error information as 8, [ (1, 0, -2147221494) ].  I have ran the Uninstall Utility levels 1-4, cleared EVERYTHING HP out of my PC, and reinstalled and STILL get the same error message. My PC is running Windows XP SP3 and the device is a OfficeJet 6500 e709a and is connected via USB. I can scan using the Windows Scan utility, can scan from the actual device, can print to the device, but for some reason, I cannot scan using HP Solution Center. After searching the web, I see that this is a common issue and wonder why there is no apparent fix. Do not tell me to reinstall and do not tell me this is a Windows problem. I tried using the FIXSCAN utility, but apparently it is only for Laserjets and just a few models of those to boot.... What is the problem and how do I fix it?

Student
joshb121
Posts: 1
Registered: ‎10-25-2009
Message 2 of 8 (6,985 Views)

Re: HP Officejet 6500 e709a Series "HP Imaging Device not Found"

I'm having the same issue with my j6480 printer.  As of 1/20/10 HP added a driver for windows 7.  This driver worked fine until yesterday (2/14).  I feel like there may have been an HP update that messed things up. I too have followed all recommended steps and even did a complete uninstall with the scrubber.  When I reload, I still have the same issue, and often, the printer itself disappears and needs to loaded again and again.

Honor Student
theitgirl
Posts: 2
Registered: ‎02-16-2010
Message 3 of 8 (6,968 Views)

Re: HP Officejet 6500 e709a Series "HP Imaging Device not Found"

Hi.  This may help if you have your printer networked:

 

I had this problem with my Photosmart C7280 too and solved it using Solution Three from the following link:

 

http://h10025.www1.hp.com/ewfrf/wc/document?lc=en&dlc=en&cc=uk&docname=c01367961

 

It made sense to me that the firewall settings were the issue given printing and faxing from my desktop wasn't an issue and my laptop detected the device via the HP web interface and the HP solutions centre.

 

I use a laptop running Vista and have a wireless network at home.  I made all the HP services/programmes I could find Exceptions in my Windows Firewall settings (accessed via Control Panel - Security Centre - Windows Firewall - Change Settings). 

 

Just to be on the safe side, as I made each of the HP programmes an exception, I changed the scope of the exception to restrict access to my private network (select the programme in the Exceptions list, click on Properties, then Change Scope and select My Network (subnet) only from the options.  Make sure you click on Apply at the end to save your settings.

 

Once I did this, I just stopped and restarted all the HP services I could find.  This meant I didn't have to shut down and restart my laptop and printer.  If you are happier to or if you are not using Windows Firewall, just follow the instructions from the link above.  If you are not using a software firewall on your computer, check the firewall settings on your router as well.

 

If you really want to be sure that the firewall settings are the issue, try connecting the printer via USB and restart both your computer and the printer.  If you can then detect the scanner then this is a sure sign that the issue is something to do with network (firewall) settings and not hardware or software related.

 

Hope this helps.

Student
cjs74140
Posts: 1
Registered: ‎08-23-2010
Message 4 of 8 (6,134 Views)

Re: HP Officejet 6500 e709a Series "HP Imaging Device not Found"

 
Honor Student
kittykkray
Posts: 2
Registered: ‎12-26-2010
Message 5 of 8 (5,373 Views)

Re: HP Officejet 6500 e709a Series "HP Imaging Device not Found"

Mine is an officejet all in one 4500 and I get the same message.  Every time my computer starts, there it is.  I can scan just fine but the message is driving me crazy. 

Top Student
learstroker
Posts: 8
Registered: ‎11-21-2010
Message 6 of 8 (5,369 Views)

Re: HP Officejet 6500 e709a Series "HP Imaging Device not Found"

I have the same problem with a C309N.  Scan error, HP imaging device not found.  Countless wasted hours with upper level tech support.  They finally told me it is microsofts fault. I have a $400 brick that floods my computer with nag warning screens.  I have win 7 64 bit.  New clean machine.  I had great difficulty with a HP 6500 wirelessly and bought this one on thier recomendation that it would work and was the latest. All worked for a month and then failed. I have been connected with USB and wireless. I have tried everything on the internet to fix this and all recomendations by HP.  I have lost all confidence in HP and wil never buy anything of thiers again.

Student
rdocblake
Posts: 1
Registered: ‎02-09-2012
Message 7 of 8 (2,486 Views)

Re: HP Officejet 6500 e709a Series "HP Imaging Device not Found"

I am having the same problem as others with my HPOfficejet 6500709a. I do not get the imaging device to work. I have uninstalled and installed both from the HP site and the CD that came with the printer. It worked before and now not.  Help

Honor Student
henrylih
Posts: 2
Registered: ‎02-29-2012
Message 8 of 8 (2,260 Views)

use both the USB and Ethernet connection

My HP6488 usually worked fine and occasionally couldn't find the image device. These two days I got the same error message as you. I can print but can't scan as the scan device can't be found, and the Solution Centre displays that the HP printer is connected.

I un-installed the HP driver and re-install the driver, nothing changed and it won't help.

I am using Windows XP SP3, then I right click the "my computer", select "properties", select "hardware" tab's "Device manager", select "Imaging devices", it shows there are two HP Officejet J6400. Then I delete the #2,

But I found the #1 is disabled, then I enable it inside the "device manager" by right click that image device's icon the select properties then select enable in the new window. After 15 seconds it disabled itself again. So I watch the HP Officejet 6400 properties window, each time I enable the printer/scanner, it works but only working for 15 seconds, then it disables itself. I don't know what causes this. But I guess it maybe the router/ethernet not stable.

I then unplug the printer/scanner's ethernet cable and USB cable, then plug them all in again. the bottom right side of the computer screen shows detected new hardware, then after one minute the new hardware is ready to use. I then found in the "device manager" I got two imaging devices again "HP 6400 and HP 6400 #2", and I notice HP6400 #2 is enabled and working while the #1 is disabled.

So I guess it's the USB cable that helps and it's more stable then wireless/ethernet connection.

 

Now I am scanning. Hope this would help you. Because I fiddled the above things without full knowledge, I am not sure if the error would come back.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation