Question
Trouble with Atheros AR5009 WLAN adapter
Replies (97)
Reply
 
Student
mhorany
Posts: 1
Member Since: ‎04-26-2010
Message 91 of 98 (5,502 Views)

Re: Trouble with Atheros AR5009 WLAN adapter

I actually found this thread by searching Google for "Atheros 5009 is horrible."  Go figure.

 

Anyway, I would just like to add myself as yet another case of the infamous Atheros 5009 wifi card unable to pick up a DHCP address from network to network.  Uninstalling and reinstalling the card from Vista/Windows 7 works sometimes, but lately it's just a shot in the dark.

 

Recently HP sent me a replacement card fearing there was something wrong with the hardware.  Two more cards later (that's right three cards total) and the same issue...unable to connect or limited connectivity.  I have not tried XP yet, but am sure it will probably work.  I will try the drivers listed in the last few posts when I get home tonight and report.  HP is as oblivious to the issue as anyone.  Below are just some of the issues I've had with this card in case anyone can relate.

 

Setup - HP G60-247CL, Linksys WRT300N

 

Would connect intially.

One day, just wouldn't connect.

Had to remove card from device manager and reinstall to connect.

Few days later, it would just stop connecting, same steps to reconnect.

 

At one point i tried chaning the securtiy from WPA2 to WPA to WEP and from AES to TKIP to both yadda yadda

Sometimes it would work for a while, but eventually it either wouldn't connect or would give me the limited connectivity icon.

 

Setup 2 - HPG60-247CL, DLink DIS-628

 

Same scenario as above intially.

 

Changed wireless router's channel since I'm in an apartment complex.  Now, it will connect to my wifi just fine, but will not accept a DHCP address from any other wireless network anywhere.

 

The card is a total piece of crap.  My linksys USB wifi adapter works great.

Honor Student
FreakShow
Posts: 2
Member Since: ‎12-16-2009
Message 92 of 98 (5,038 Views)

Re: Trouble with Atheros AR5009 WLAN adapter

I've have two of these adapter on laptops. They are sluggish and respond slowly. One is now totally dead it seems it shows my network and asks for my password I can enter all day long and it will not except it as being correct.

 

Does anyone know where to purchase a replacement? Preferably another brand.

Honor Student
ChaserB2
Posts: 3
Member Since: ‎08-10-2010
Message 93 of 98 (4,953 Views)

Re: Trouble with Atheros Disappearing WLAN adapter

I REALLY like your tag line!!!!!!

 

By the way, I too have the disappearing wireless problem:

(Atheos) wireless card and my system says it doesn't,,, go figure.

If you know how to make it reappear, pls. let me know-

My system:

HP G60 Notebook PC
Product # NV225UA#ABA
Warranty: 7/22/2022
Windows Vista Home Premium
Service Pack 2
AMD Turion Dual Core RM-75 2.20 GHz
3.00 GB Ram
32 Bit Operating System

Student
HPCraaaap
Posts: 1
Member Since: ‎12-21-2010
Message 94 of 98 (4,182 Views)

Re: Trouble with Atheros AR5009 WLAN adapter

I have a CQ50 that has this issue with the ar5009.    If I delete the card under device manager and then rescan for changes and reinstall it will work again for a couple of restarts.    There is another peculiar issue with this is that sometimes the driver won't install correctly giving an error.  If I depress the crappy blue/red button once and then

reinstall the device it will work then.    Hp fix this!!!!!! 

Honor Student
markni
Posts: 3
Member Since: ‎04-30-2009
Message 95 of 98 (4,138 Views)

Re: Trouble with Atheros AR5009 WLAN adapter

I had the same problem(s).  This driver seems to work for me now:

http://www.atheros.cz/atheros-wireless-download.php?chipset=43&system=3

 

Try it and see if this works.

Intern
Martini
Posts: 17
Member Since: ‎07-15-2010
Message 96 of 98 (3,589 Views)

Re: Trouble with Atheros AR5009 WLAN adapter

Hi.

 

I had similar problems with AR5009 on a Compaq CQ70-120US.

 

It was having 50% package lost with a simple ping to the wireless router that was by the laptop side.

The default driver that Windows 7 installed for the AR5009 was 2.0.0.75 (09/06/2009), which gave me this problem.

 

I installed sp46631.exe and changed the driver to

7.7.0.319 (25/05/2009) and now it works without problems.

 

Haven't tried yet the other link to the Atheros web site, but this SP46631 seems to do the trick fine for the moment.

 

martin

Tutor
roger1owen
Posts: 8
Member Since: ‎09-03-2011
Message 97 of 98 (3,164 Views)

Re: Trouble with Atheros AR5009 WLAN adapter

I've just read your bit about turning wireless off each time before shutdown and it's worked for me for past months - clumsy but... But now even that doesn't work anymore nor does uninstall/reinstall. It's just like it's one step ahead. Is your 'clumsy' fix still working?

Student
WHO1289
Posts: 1
Member Since: ‎06-28-2013
Message 98 of 98 (539 Views)

Re: Trouble with Atheros AR5009 WLAN adapter

YOU KNOW I HAVE THE SAME PROBLEM AND BEEN GIVIN THE RUN AROUND , I'VE EVEN HAD A TECH SUPPORT FROM A OUTSIDE SOURCE TELL ME IT'S GOING TO COST 49.95 TO SOLVE THE PROBLEM, I'VE DONE EVERYTHING YOU COULD THINK OF AND I COME UP WITH CODE 10>THE DEVICE CANNOT START AND I'M RUNNING WINDOWS VISTA 32 BIT HP G60-243CL. I'M SURE GLAD I JUST BOUGHT A APPLE MACBOOK PRO, BUT IN THE MEAN TIME I THINK I'LL JUST REINSTALL AND SEE WHAT HAPPENS. WELL GOD BLESS EVERYONE AND THE BEST OF LUCK ON THIS >AR5009 802.11a/g/n  WiFi ISSUE !!!!!!!!!!!

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation