Question
Reply
Honor Student
Posts: 3
Member Since: ‎01-05-2010
Message 1 of 28 (14,309 Views)

keep losing wireless connection with Atheros AR9285

Just bought an HP Pavilion dv7-3065dx with a Atheros AR9285. The wireless connection keeps dropping and i have to troubleshoot it every few minutes. Windows Network Diagnostics resets the adapter each time. Than a few minutes later it drops again. I have 2 other wireless computers that work fine when connected to the router including a HP dv9000. Already talked to tech support and updated the drivers and the bios. Any suggestions?

Reply
0
Tutor
Posts: 14
Member Since: ‎12-03-2008
Message 2 of 28 (14,291 Views)

Re: keep losing wireless connection with Atheros AR9285

What is the Security on your wireless router? If it is WEP then there is an issue with Windows 7 and vista 64 bit operating systems. Switch the security on the router to WPA and see if that fixes the issue.

DV3t-2000, Intel core 2 Duo P7350, 4 GB ram, 500 GB HDD, Nvidia GeForce G 105M, Windows 7 Ultimate
Honor Student
Posts: 3
Member Since: ‎01-05-2010
Message 3 of 28 (14,279 Views)

Re: keep losing wireless connection with Atheros AR9285

It is WPA and my HP dv9000 works fine with it which is running Vista 64 bit. Have worked a second time with Tech Support and they couldn't solve the issue either. I have a feeling i have a bad controller.

Tutor
Posts: 15
Member Since: ‎12-30-2009
Message 4 of 28 (14,278 Views)

Re: keep losing wireless connection with Atheros AR9285

I've got the same problem.

 

HP told me to "install newest driver" et cetera, blah :smileyindifferent:

 

I'm using new driver: 8.0.0.238 and it still drops connection!

 

But it is not the router problem, because Wifi adapter without connection lose a wireless networks also! [I mean I am unable to connect to any network after 15 minutes, it refuse to work].

Honor Student
Posts: 3
Member Since: ‎01-05-2010
Message 5 of 28 (14,246 Views)

Re: keep losing wireless connection with Atheros AR9285

[ Edited ]

I went out yesterday and upgraded my router from the Linksys Wireless N home router (WRT150N) which I bought a few years ago to a Simultaneous Dual-Band Wireless-N Gigabit Router from Linksys (WRT610N). So far it seems to have solved my problem. I have not lost connection since last night. I will update this in a few days or sooner if I start loosing connection again.

Tutor
Posts: 15
Member Since: ‎12-30-2009
Message 6 of 28 (14,237 Views)

Re: keep losing wireless connection with Atheros AR9285

What drivers and what Windows do you use?

Top Student
Posts: 3
Member Since: ‎01-09-2010
Message 7 of 28 (14,167 Views)

Re: keep losing wireless connection with Atheros AR9285

How have things been with your new router? Can you advise what version of driver you're using (from device manager)?

Top Student
Posts: 9
Member Since: ‎01-09-2010
Message 8 of 28 (13,957 Views)

Re: keep losing wireless connection with Atheros AR9285

I have the same problem but with a dv7 306l  and a athreos 9285 wireless card, It came with vista and it dropped out so i upgraded to wind0ws 7 and its got worse  every 10 minutes it keeps dropping out.

 

 

I have tried the usual latest drivers blah blah, but still doesn't work. its not the router because of my dell works fine.

 

I have even taken off dhcp and given all my wireless devices a decicated ip address  but still havn't cured the problem. I cant try another router because i am with sky and they will not give you your username and password, I have tried it around my dads house it still drops out.

 

I thinks this is a driver/ hardware issue

Top Student
Posts: 9
Member Since: ‎01-09-2010
Message 9 of 28 (13,785 Views)

Re: keep losing wireless connection with Atheros AR9285

It's a hardware fault mine has done the same, HP change the card I installed it and now it works fine no drop outs on the wireless. Ask them for a new card.

Student
Posts: 1
Member Since: ‎04-11-2010
Message 10 of 28 (13,300 Views)

Re: keep losing wireless connection with Atheros AR9285

I have network dropping with CQ61-210SQ and AR9285, Windows XP. Looks like network dropping happens only when N mode enabled in ruter. And with constant network traffic for long time, and not necessarily at top speed.

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation