Having trouble signing in? Try this!
Post new question
Question
Reply
 
Tutor
Posts: 11
Member Since: ‎06-24-2016
Message 1 of 2 (254 Views)

SoftPaqs: Versions of drivers vs models supported. Should we always install the latest?

Operating System: Microsoft Windows 10 (64-bit)

Hello all,

 

one simple question that any HP expert should know the answer to.

 

I am trying to build OSD for a series of HP models (both desktops and laptops).

It seems like there are multiple versions for any software or drivers included in different softpaqs.

 

For example:

 

Class    Driver            Version        SoftpaqID   ModelsSupported
-----    ------            -------        ---------   ---------------
Software HP Hotkey Support 5.0.28.1 Rev.A sp71790.exe EB820G1:EB840G1:EB850G1
Software HP Hotkey Support 6.2.16.1 Rev.A sp76281.exe PD400G3MT
Software HP Hotkey Support 6.2.29.1 Rev.A sp77566.exe EBF1040G2
Software HP Hotkey Support 6.2.34.1 Rev.A sp79266.exe EB820G2
Software HP Hotkey Support 6.2.37.1 Rev.A sp79849.exe ZBG3
Software HP Hotkey Support 6.2.39.1 Rev.A sp81790.exe EB820G3:EB840G3:EB850G3:ED800G3DM
Software HP Hotkey Support 6.2.41.1 Rev.A sp84846.exe EB820G4:EB840G4:EB850G4:EB830G5:EB840G5:EB850G5

 

My question is:

 

Can we use the latest version for all models? It seems like that should be the proper way to go.

The above are taken directly from HP Support Pages for our current fleet. BUT, I found out that version 6.2.41.1 (the latest) within its CVA file it says that it has superceded version 6.2.39.1 Rev.A. So, only after opening the specific CVA I was able to see that what HP Support pages provide (as well as SSM) is not current.

 

The same would apply to the chipset drivers, graphics drivers etc. It really doesn't make sense to deploy numerous versions to our fleet when the latest should cover for all.

 

Any answers, kindly be with specific knowledge.

 

 

Thanks a lot!

Reply
0 Kudos
Highlighted
Tutor
Posts: 11
Member Since: ‎06-24-2016
Message 2 of 2 (245 Views)

Re: SoftPaqs: Versions of drivers vs models supported. Should we always install the latest?

Another great example is below:

 

Chipset-ME Intel Management Engine Software          11.0.0.1158 Rev.B sp74499.exe WSZX20
Chipset-ME Intel Management Engine Components Driver 11.6.0.1045 Rev.A sp79059.exe EB820G1:EB840G1:EB850G1:EB820G2:EB840G2:EB850G2:ZBG2:EBF1040G2:PD400G3MT
Chipset-ME Intel Management Engine Driver            11.7.0.1035 Rev.A sp82015.exe ED800G1DM:ED800G1TWR:ED800G1USDT:PD600G1DM:PD600G1SFF:PD400G2MT:ED800G3DM:ED800G3SFF
Chipset-ME Intel Management Engine Driver            11.7.0.1045 Rev.A sp82469.exe EB830G5:EB840G5:EB850G5:ED800G2SFF
Chipset-ME Intel Management Engine Components Driver 11.7.0.1045 Rev.W sp82472.exe EB820G3:EB840G3:EB850G3:EB820G4:EB840G4:EB850G4:ZBG3
Chipset-ME Intel Management Engine Software          11.7.0.1065 Rev.A sp84650.exe WSZX40

 

Although there are numerous softpaqs, if we look inside the CVAs, we see a very limited set of HP Models as Supported.

BUT if we actually have a look inside the .inf files of the drivers, they are proper Intel drivers and support all of the models.

 

 

 

Thanks,

Alex

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation