cancel
Showing results for 
Search instead for 
Did you mean: 
Mikhail123
New member
3 1 0 0
Message 1 of 4
404
Flag Post

BIOS will not assign a BAR to Region 1 for GPU device as GPU is requesting 16GB of PCI I/O space

HP Recommended
XW8600
Linux

trying to install a Nvidia P100 GPU for CUDA software compute (not for graphics display).  The P100 is a PCIe Gen 3 x16.  

 

The P100 is requesting 16GB PCI I/O memory for mapping BAR Region 1 and it's showing as "Unassigned".  BAR Regions 0 and 2 are showing up as "Assigned" 16MB and 256MB respectively.

 

I have 32GB of Memory installed in the unit and have updated BIOS to V1.46 (which was latest available on hp support)

 

How do i get the BIOS to map a 16GB (Giga-Byte!!) BAR1 Region 1 PCI I/O address space.

 

Please help.  

 

 

Mondo

 

Tags (2)
3 REPLIES 3
DGroves
Level 11
4,481 4,464 406 933
Message 2 of 4
Flag Post
HP Recommended

i believe that you have to set the PCI(e) slot the p100 card is in to "compute=yes" in the BIOS-settings

if the z820 has this option, as it tells the system not to see the card as a video device

 

warning,..........do not select the pci-e slot that your "MAIN" video card is using or you will not have a working system!!!!

you must have at least one pci-e set as normal in order to have working video!!!!

 

pci-e slots are numbered from the top towards the bottom,  so you would never select pci-e slot 0/1

 

the above is from memory since i can't test this option right now on my z820 (as i'm using it)

 

you can also try disabling unused resources in the Bios, such as the second network card, or the onboard LSI SAS controller

 

0 Kudos
Mikhail123
Author
New member
3 1 0 0
Message 3 of 4
Flag Post
HP Recommended

Hello Sir,

 

My Server is Model XW8600 (not Z820 as you reference below).  I do NOT have such option in my BIOS (v1.46 which is latest) that allows me to set the PCIe slot 4 (or any PCIe slot) to Compute mode.

 

My ONLY option for PCIe slot(s) is "Slot x Option ROM Download - PCIe x16   >Enable/Disable"

 

I do NOT have any other option(s) below to set PCIe slot to "Compute" or "Normal"???

 

I an using xw8600 BIOS v1.46 which was the latest i found for Server HP xw8600.  Please advise if i have any other BIOS option that provide me the "Compute" mode option for PCIe Slot(s).

 

Thank you.

0 Kudos
DGroves
Level 11
4,481 4,464 406 933
Message 4 of 4
Flag Post
HP Recommended

then try following THE OTHER RECOMENDATIONS I POSTED PREVIOUSLY

 

also stating which distrubition of linux you are using would be most helpfull  when you are asking for help

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation