cancel
Showing results for 
Search instead for 
Did you mean: 
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
Highlighted
New member
6 5 0 0
Message 1 of 11
493
Flag Post

HP Z Turbo Drive G2 on Z640 Workstation

HP Recommended
HP Z640

Hi All,
I have a HP Z Turbo Drive G2 (E203413) but I could not see the drive for the boot order on HP Z640 workstation. I couldn't see the drive even after I started the system with CentOs or Fedora 32 or Debian. I ran the windows 10 and Linux installations, neither one didn't show me the Turbo Drive for the installation.

I bought this system from another person, he said all worked fine and he only replaced the SSD to a new HP SSD (S700 M.2 500GB) since he needed the old SSD. 
The bios version: M60 v02.54 (I updated the bios to the latest)

I reset the bios to factory settings with no joy.
I don't think anything wrong with the hardware. Can anyone tell me what could be a problem?
Thanks in advance.
Anton

 

PS: I tried CMOS reset & SATA controller mode to AHCI.

10 REPLIES 10
Highlighted
Level 10
1,998 1,953 179 567
Message 2 of 11
Flag Post
HP Recommended

It is tricky.  I needed to set BIOS to factory defaults.  Then put in the ZTD G2 into the advised PCIe slot.  Then booted off an original installer DVD that came with the Z640, for W10, and that included the drivers for targeting the ZTDG2 in BIOS for the old W10 install.  Then updated that to W10 2004 upgrade.

 

If the BIOS for a Z620 was not complex enough that the the Z640 surely is...  doing this all from scratch is not intuitive.  Don't forget that there is a HP cloud based ZX40 W10 restore option that exists for this generation of workstations, but not for any  earlier ones.

 

If all this seems over the top it is best to stick with SATA gen III SSDs.  The ZTDG2 is faster, but not by that much on a practical level, and has been a PITA to master.

Reply
0 Kudos
Highlighted
Author
New member
6 5 0 0
Message 3 of 11
Flag Post
HP Recommended

Hi SDH

Okay, I'll try to get hold of the original installer DVD for W10 and try again.
I've seen some youtube videos that show the boot option on the bios setup contains the ZTD G2 as a drive. I don't see the ZTD G2 on boot option. Shouldn't we see this option on bios? I understand W10 may not show the selection if there is no driver but bios must show the ZTD as a boot selection, am I wrong?

I am using the slot 4 (as specified) for the ZTD G2. 

 

Thank you

 

Reply
0 Kudos
Highlighted
Level 10
1,998 1,953 179 567
Message 4 of 11
Flag Post
HP Recommended

You are doing the right things.  I too had a phase where it did not show in BIOS.  To be honest I used every trick in my book and am not sure which got me the breakthrough.  There are the advanced methods to combat a "stuck" option in BIOS or some small BIOS corruption that may be holding you back.... try those.  There is the BIOS defaults and the BIOS factory defaults... make sure you're setting to the factory defaults after the advanced BIOS/CMOS clear steps.

 

I saw what you are seeing and got through that, but had given up on documenting what I was doing at each step because it just went on and on.  Then came the pleasant surprise.... it was a project success, which is fun, but I do agree with our friend Bambi here that a nice modern SATA SSD plugged properly into a SATA III port is mighty fine.

Reply
0 Kudos
Highlighted
Author
New member
6 5 0 0
Message 5 of 11
Flag Post
HP Recommended

Thank you for your response. I'll try the way you suggested (Factory defaults after the CMOS clear).
I almost gave up any hope of using the ZTD G2 but judging from your response, you had the same problem so I'll try again. Since it is there, bit reluctant not to use it. I am not too much bothered about booting from ZTD, it would be a nice addition to use that disk as a scratch disk for 4K editing.

 

Thanks

 

Reply
0 Kudos
Highlighted
Author
New member
6 5 0 0
Message 6 of 11
Flag Post
HP Recommended

I have tried all possible settings on BIOS, nothing else left for me to try as far I know. Still no luck.
ZTD website says I don't have to do anything if I wanted to use that as a data drive but my Win 10 or Linux is not seeing the drive at all. Apart from this, the system is working fine, I don't think any hardware issues, all the PCIe slots are functioning okay if I plug other PCI devices.  Although I don't think anything wrong with the ZTD card, I ordered a new card to put that nagging doubt aside. 
I tested the SSD and it is working fine - actually it is a new SSD.

 

Thank you

Reply
0 Kudos
Highlighted
Level 10
1,998 1,953 179 567
Message 7 of 11
Flag Post
HP Recommended

Your instincts may be right.  Perhaps it is a bad M.2 stick on the HP PCIe card.  Also, sometimes people sell the HP PCIe card with a HP stick on it that was originally for another purpose, and that stick might not have the necessary firmware from HP installed.  I actually have two of the HP PCIe cards which have two different Lenovo 512GB M.2 sticks which run fine on the Z440 and Z640 workstations, also.

 

There is a HP BIOS feature called Replicated Setup.  I could capture my exact Z640 settings and send them to you.  You can capture yours to set aside.  You could then load mine and try those.  Then you can reload yours.  This is a way we clone our BIOS settings easily.  PM me in the forum here if you want me to send you that small text file the process generates.

 

As I said before I set my BIOS to factory default during the clean install, but then after I get things working with that I do fine tune BIOS and still have the ZTD G2s working on this box.  So, I'd send you the fine tuned version.

Highlighted
Level 10
1,998 1,953 179 567
Message 8 of 11
Flag Post
HP Recommended

I wanted to add.... I do have one HP M.2 stick that I never have been able to get working in any of our ZX40 workstations with the HP PCIe G2 card, but that stick was from another HP box.... a HP business class PC, and that is why I think its firmware is not for the ZX40 workstations.

Reply
0 Kudos
Highlighted
Level 10
1,998 1,953 179 567
Message 9 of 11
Flag Post
HP Recommended

Done, and thank you for the tip on the new version of BIOS for the Z440/Z640/Z840 released mid June last month.  I updated my BIOS before capturing the settings... so you have the latest settings with that taken into account.

Reply
0 Kudos
Highlighted
Author
New member
6 5 0 0
Message 10 of 11
Flag Post
HP Recommended

Thank you very much for your time but sadly it didn't help. I'll wait for my new ZTD G2 to try again.

 

 

 

Reply
0 Kudos
Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation