cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 11
3,190 3,182 270 626
Message 21 of 32
314
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

you keep ignoring my requests for information so i will try one last time

 

Did you download and install the CORRECT intel 4.5.10.1021 drivers using the direct link i gave you? please confirm

 

https://downloadcenter.intel.com/download/28189/Intel-Rapid-Storage-Technology-enterprise-Intel-RSTe...

 

have you connected the 4tb sas drive DIRECTLY to a "SCU" port using a sata/power cable (DO NOT USE THE LSI PORTS)

the scu ports are next to the two native  grey or blue SATA ports again yes or no

 

did the 4tb drive show in the bios after connecting it to the "SCU" port?

Reply
0 Kudos
Highlighted
Level 1
16 15 0 0
Message 22 of 32
295
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

Thank you

 

Did you download and install the CORRECT intel 4.5.10.1021 drivers using the direct link i gave you? please confirm

Yes. i did..please see the first 4 these pictures.. i run IATA_CDCapture14.PNGCapture11.PNGCapture12.PNGCapture13.PNG


have you connected the 4tb sas drive DIRECTLY to a "SCU" port using a sata/power cable (DO NOT USE THE LSI PORTS)

the scu ports are next to the two native grey or blue SATA ports again yes or no

Yes.. When I replace the DVD with the 4 tb SATA drive and plug the power cable and sata cable  in one for scu ports ( 1 from 4 ) .. it would not shows on bios or Wind10x64

But if I do the same with newly sealed SSD drive, it shows in bios but not in the Windx64

 

20191218_080210.jpg20191218_081605.jpg

Reply
0 Kudos
Highlighted
Level 11
3,190 3,182 270 626
Message 23 of 32
290
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

the entries listed as "Windows Boot Manager" are bootable storage devices , this is how they are shown under UEFI

 

next again i'm confused why would you need to move the DVD sata cable?? it should be connected to one of the two grey/blue native SATA ports along with the boot drive

 

please remove "ALL" hard drives/storage devices from the system, this includes any USB storage devices

 

now, connect JUST THE 4TB sata drive to one of the grey/blue native sata ports and enter the bios, does it show in the bios or as a "windows boot manager" entry

 

now do the same with your boot disk, again what goes the bios show

 

you appear to have two SSD's a MX500 and a 860 evo which is the boot disk?

 

Reply
0 Kudos
Highlighted
Level 1
16 15 0 0
Message 24 of 32
262
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

Thank you

 

next again i'm confused why would you need to move the DVD sata cable?? it should be connected to one of the two grey/blue native SATA ports along with the boot drive

-Just to eliminate any issues with power cable that is way i used to one from DVD source instead the one coming from drive bay

please remove "ALL" hard drives/storage devices from the system, this includes any USB storage devices

 

-Yes.. I done this ... only one disk a time.. no other storages attach.. not even the DVD

SSD MX500 is the bootable drive, can be seen in Bios and load Wind10x64 properly, no issues, connected to grey native sata

1.jpg

 

2.jpg

 

now, connect JUST THE 4TB sata drive to one of the grey/blue native sata ports and enter the bios, does it show in the bios or as a "windows boot manager" entry

 

3.jpg

 

4.jpg

 

 

-But When i test this with SATA Seagate 4tb storage nothing is showing, connected to the same port the grey native sata as previously

 

you appear to have two SSD's a MX500 and a 860 evo which is the boot disk?

-860 evo was new sealed drive.. used it here to test, pluged it to the second native sata port, where i had my DVD on... shows in Bios but not in Wind10x64.. note when I plug the DVD instead in the second native port .. it shows in Bios , and in Windows but it does not work!!

Reply
0 Kudos
Highlighted
Level 11
3,190 3,182 270 626
Message 25 of 32
255
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

with the mx500 attached to sata 0 and the 1tb evo attached to sata 1,.... boot the system

 

in the bios confirm both drives show, and are connected to the correct ports then reboot into windows

 

ALL NEW HARD DRIVES MUST BE PARTITIONED BEFORE THEY CAN BE USED

 

read the link below,

 

https://www.windowscentral.com/how-format-new-hard-drive-windows-10

 

let me know the result

Reply
0 Kudos
Highlighted
Level 1
16 15 0 0
Message 26 of 32
240
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

thank you

 

yes. both SSD drives show in Bios

 

Mx500 is the boot drive.. working fine.. Sato0

 

But the 1tb evo . Sato1 is not showing on Wind10 x64 or in Disk manangement to format it or to  partition it.

 

20191219_092523_001.jpg

 

20191219_092447.jpg

 

20191219_092042.jpg

 

20191219_092016.jpg

 

20191219_091945.jpg

 

Reply
0 Kudos
Highlighted
Level 11
3,190 3,182 270 626
Message 27 of 32
229
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

at this point i would back up any data you wish to keep and with only the mx500 installed (and a DVD or usb key) and reinstall windows 10, (remove any existing partitions during the setup)  then only do the MS updates do not install any other drives except for what MS gives you

 

once the mx500 is done, install the 1TB evo, and see if disk mgmt can see the drive

Reply
0 Kudos
Highlighted
Level 10
1,869 1,825 170 526
Message 28 of 32
202
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

Big kudos to DGroves for his patience and knowledge on the W10 ZX20 Storage Controller driver issues.  For those who don't know, there will be no ZX20 Storage Controller driver updates from Intel for the motherboard chipsets, after 4.5.0.xxx.  Those chipsets are now EOL.  Those workstations will live on many years, however.

 

I recently did a full true clean install of the most recent W10 onto a clean freshly formatted SSD on a Z420 v2 workstation.  I usually do these as starting with a very tuned HP OEM COA W7Pro64 to get the free registration to W10Pro64.  I then launch the setup.exe on the downloaded MS W10 installer thumb drive, and upgrade that to W10 (choosing the "save nothing" option).  The result for years has been no difficulties or "yellow bangs" in Device Manager.  Not so for this clean build.... I did not have the usual "Storage Controller" Device Manager main section with the usual 3 entries I usually see from a normal upgrade install.  Rather, the driver was single, yellow bang, something I've never seen, and "15."x from Microsoft.  Sorry, no pics.

 

With the advice from this thread I was able to download those latest 4.5.10.1021 drivers, presented by Intel as the last driver set, and then used the "IATA_CD.exe" launch option that the OP used.  This launch .exe is inside the GUI folder only.  That auto-updated the clean install.  Automatically I ended up with all 3 usual drivers and a new Storage Controller main entry in my clean install's W10 Device Manager.  The "15" one and its entry disappeared.  Note that these drivers were built in 2015, for W8, but now Intel says they are for W10 also.  They must have done some extensive testing.

 

Later drivers than 4.5.x will not ever work...... until the next quirk.

 

I was stuck at how to upgrade the drivers if I did not already have that main section in the W10's Device Manager.  I know how to do the F6 individual driver update method, but this worked perfectly without even having a target for that process.

Reply
0 Kudos
Highlighted
Level 11
3,190 3,182 270 626
Message 29 of 32
195
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

To "SDH" there are also4.6.0.2116 drivers that also work on the z820's however these drivers were/are OEM releases and the only difference that i could find with them is they also support the intel optane products, they do however come with F6 drivers i recommend users stay with the 4.5 rste driver as it's fully compatible with the z820 however it appears that the 4.7 rste driver may also work but keep in mind it may not work as well or as fast as the 4.5, this is something the end user will need to test for themselves and if you query the 4.5 setup.exe app you will get the switches to extract all the files contained in the 4.5 installer including the "F6" drivers

 

and win-raid shows the 4.7 driver they list still has support for the z820's c600 series chipset

 

https://www.win-raid.com/t2f23-Intel-RST-RSTe-Drivers-latest-v-WHQL-v-WHQL.html

 

Latest/best Intel RSTe drivers of the v4.x platform (for X79, X99 and other C600/C600+/C220 Series Chipsets):

 

 

 

 

 

 

 

 

 

 


Notes: This package contains all above listed Intel RSTe AHCI/RAID drivers v4.7.0.1098 WHQL and the Intel RSTe Console Software v4.7.0.2072, all dated 11/24/2017. It is only suitable for Intel C600/C600+/C220/C220+ Series Chipset AHCI/RAID systems like X79 and X99. All Windows Operating Systems from Win7 up to Win10 are supported. Thanks to lfb6 for the info and the link to the source package.
Best matching Intel RSTe SATA RAID ROM/EFI BIOS modules: v4.7.0.1017

 

 

Reply
0 Kudos
Level 10
1,869 1,825 170 526
Message 30 of 32
193
Flag Post
HP Recommended

Hp Z820 can not see 3 Sata drives

Thanks much DGroves.... the "quirk" came faster than I expected.  I'm just happy to get rid of the yellow bang I had using your excellent advice.  Best....

Reply
0 Kudos
Be alert for scammers posting fake support phone numbers on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation