cancel
Showing results for 
Search instead for 
Did you mean: 
Jesp90
Level 1
11 10 0 0
Message 1 of 26
1,276
Flag Post

MSI nVidia 210 in Z4 G4 Workstation

HP Recommended
Z4 G4
Microsoft Windows 10 (64-bit)

Hi,

 

I just received an HP Z4 G4 workstation without a graphics card. As I don't need that powerful graphics I decided to use an MSI nVidia 210 that I had lying around. With this card correctly inserted in the PCI-E 3.0x16 slot I get nothing on the screen. I also tried another older card and got the same problem. Is this computer not supporting "unprofessional cards"?

How do I proceed? 

Thanks,

Jesper Larsson 

25 REPLIES 25
DGroves
Level 11
4,502 4,485 410 940
Message 2 of 26
Flag Post
HP Recommended

i believe you have to enter the BIOS, and tell the sysem to use the pci-e card as a primary display device or it will default to the onboard graphics and ignore the pci-e card

 

also  under windows 10 there is a notice on issues with a second video card and the nessary fix

 

 

https://support.hp.com/in-en/document/c05916505

0 Kudos
Jesp90
Author
Level 1
11 10 0 0
Message 3 of 26
Flag Post
HP Recommended

Thanks for your answer! I would like to do that, but this computer doesn't have any integrated graphics. Is there a way to tell the computer to use PCI-E anyway?

0 Kudos
DGroves
Level 11
4,502 4,485 410 940
Message 4 of 26
Flag Post
HP Recommended

the z4 supports wide range of cpu/gpu options , and as it's a new line from HP i have not actually worked on one yet

 

do you get a display with the original video card and if so what card model is it?

 

 

0 Kudos
Jesp90
Author
Level 1
11 10 0 0
Message 5 of 26
Flag Post
HP Recommended

It was shipped without a graphics card (mistake on our end), so I never got to try it with the "original" card.

0 Kudos
DGroves
Level 11
4,502 4,485 410 940
Message 6 of 26
Flag Post
HP Recommended

can you test the card/video display  on a known working system?

 

i have seen cases where the display was not auto switching between the various inputs DVI/HDMI/VGA

and had to be manually selected

0 Kudos
Jesp90
Author
Level 1
11 10 0 0
Message 7 of 26
Flag Post
HP Recommended

I have tried two different graphics cards, and also two different displays. All with no luck using either VGA/DVI/HDMI, manually selecting input mode on the displays. I can't really think of anything more to test. 

0 Kudos
DGroves
Level 11
4,502 4,485 410 940
Message 8 of 26
Flag Post
HP Recommended

how long are you waiting for the display on the z4 ?  this workstation will take over 15 sec before outputting a video signal

0 Kudos
Jesp90
Author
Level 1
11 10 0 0
Message 9 of 26
Flag Post
HP Recommended

I waited several minutes on each of the outputs without any luck. I will do another test tomorrow when I get back to work. I really appreciate your help!

0 Kudos
Jesp90
Author
Level 1
11 10 0 0
Message 10 of 26
Flag Post
HP Recommended

I have tried everything I can think of, still no luck getting anything on the screen. Could it be a BIOS setting that I need to change?

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation