Post new question
Question
Reply
 
Highlighted
Student
Posts: 1
Member Since: ‎05-19-2017
Message 1 of 1 (527 Views)

Can't find required Intel ME drivers

Product Name: ProDesk 600 G1 Tower PC
Operating System: Microsoft Windows 7 (64-bit)

Hi,

 

I'm trying to secure our desktops against Intel AMT vulnerability but I'm having some issues.

 

The problem is that the firmware update that I'm supposed to install requires Intel Management Engine Components driver v11.6 or later. We have 11.0 and I can't find newer version from the product's (ProDesk 600 G1 Tower PC) software & drivers page, the one available seems to be even older than our current version.

 

Some other models like ProDesk 800 G3 have the required version, but I don't know if those are compatible with our model.

 

Where can I find the 11.6 version of the drivers for 600 G1?

 

Thank you

Reply
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation