cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Level 2
11 10 1 3
Message 1 of 12
552
Flag Post
HP Recommended

Designjet 510 wont align

designjet 510
Microsoft Windows 10 (64-bit)

So... this weird thing started to happen after i have printed an canvas... maybe a coincidence maybe not.. so.. lets ear if someone else had this issue with a 510 designjet plotter... 😁

 

So... i printed a design on a canvas.. and all went great. After that i tried to print a regular paper and the black print-head was giving me issues. So i removed the print head... primed it.. cleaned the contacts.. and re-inserted it. The plotter then accepted the print-head.. but i needed calibration.. so it went to calibration mode. The thing is.. when it should be starting calibrating it just goes out of the menu and cancels the print-head calibration.. without further information... (really... it just goes out and cancels the calibration)

 

It wont print because it want  the print-head calibrated.. but.. it wont calibrate as well.  Then.. after a while trying to force it to calibrate it gives me random errors such as black print-head failure (error 0030, but sometime it does read the print-head ok)... cyan print-head failure...  79:04.. generic firmware error codes as well..

 

I had another black printhead on hand from another printer and it fails just the same at random.. so... a damaged cyan can make a false error on the black printhead (as i have not tested a cyan head yet)

 

I have disconnected and connected the trailing cable.. even reconnecting the flexes on the carriage unit just to make sure it was not a bad contact... it is not. Do you guys think that a faulty trailing cable could do this?! Has the canvas printing anything to do with this or was this just a bad timing coincidence? 

 

i have even updated the firmware.. but without any improvement on the situation to report...

11 REPLIES 11
Highlighted
Level 1
11 9 0 0
Message 2 of 12
521
Flag Post
HP Recommended

Designjet 510 wont align

I don't like this "primed it", it can mean anything including i washed it under the tap.

Regardless, lets see if I can bring some new ideas.

 

So far I think black is at fault.

 

You've tried another one from anothe rprinter. Can you try yours in that printer?

Is there a log of errors you can have a look into to see the events?

You've also reconected cables and the error presisted, what about leaving cables not connected?

Or leaving something out, forcing it to report <<name>> missing?

 

If it can detect something missing, I'd make sure it can detect a few of the same things missing, like several printheads. This would at least mean that not only logic should be fine but the cables too.

 

However, not many trings can cause software to cancel an action without anything.

Suspecting a glitch, factory rest should help.

Another thing that might have caused this is damaged contact pads, causing a short. This is why i think black is at fault, well rather its nesting area.

Now that I tink of it, if it recognized printheads, began the calibration, it is possible that if problem accours during calibration, movement is at fault.

Meaning, if anything that moved during calibration has lets say coating on a wire damaged, it can short to ground and cause procedure to stop. Perhaps even a internaly broken cable can cause this if a signal goes missing so procedure just resets.

Black is fine, check cables? It also makes sense if it gives you random errors. Random shorts or sandom missing signals = random errors.

Reply
0 Kudos
Highlighted
Level 2
11 10 1 3
Message 3 of 12
499
Flag Post
HP Recommended

Designjet 510 wont align

ok .. i will do that later on today or tomorrow. By "priming" i mean using the syringe with the silicone adapter (and ink funnel) on a dedicated plastic frame in order to remove any air bubbles inside by cycling the ink within..

 

Shorted pads do make sense... 

 

I have however noticed something on the alignment procedure that i dont recall if the plotter doing it before.. (maybe it did.. i just dont remember if it did).. whenever the plotter is going to calibration sequence the YY Axis moves a little in a non-smooth-and-linear way (i am referring to the roll the feeds the paper) ... you know.. (and because i am missing a better term to express myself) like.. if the YY Axis had a controlled tourette syndrome spasm..

Reply
0 Kudos
Highlighted
Level 6
276 276 27 46
Message 4 of 12
428
Flag Post
HP Recommended

Designjet 510 wont align

Two things to try:

1: Try cleaning the linear encoder strip. Use a soft, lint-free cloth dampened with water and carefully wipe down the linear encoder strip by folding a damp piece over the top edge and lightly pinching it with your fingers, slide it along the strip to the ends.

 

2: Perform a Power Reset to eliminate a possible logic or power issue:
1) First, make sure the printer is plugged straight into a wall outlet and not a power strip, surge protector or UPS.
2) With the printer plugged in and powered ON, disconnect the power cord from the printer. This will hopefully dissipate any electricity stored in the printer that could be causing a problem.
3) Wait at least 30, preferably 60 seconds.
4) If you don't have an actual ON/OFF switch, press and hold the power button for about 10-15 seconds a couple of times in the beginning just to be sure it tries to drain the power fully. Make sure any other cables, other than power, are removed when you try to power it up again.
5) If there is a power switch, turn it to the OFF position.
6) Plug the power cable back into the printer.
7) Turn the printer ON with the power switch.

Reply
0 Kudos
Highlighted
Level 2
11 10 1 3
Message 5 of 12
346
Flag Post
HP Recommended

Designjet 510 wont align

Well...

   i have made a power reset.. replaced printheads...  cleaned the contacts.. the encoder strips... etc... but.. the error remains. Whenever it goes to alignment procedures the paper feed roll kinda goes not-so-smooth (like a small twitch) and the carriage actually goes out of the service station right to the end of the other side of the printer and then back to the service station before failing (does this 3 times.. then fails and randomly and states that 1 of the two left print-heads needs replacement.. either cyan or black.. randomly). Is there anyway i can check a system error log on this plotter?

 

   By the service menu (Green Arrow Enter + UP Menu) the last 3 errors are as follow :

 

Last error : 79:04 --> ids.c 709

Previous error : 01:10 -> NUMEepromTAG.C 3376

Previous errpr : 01:12 -> sequence.c 960

 

 ...so... any ideas? Could it be the trailing cable?? Is there a way to make service tests on any of these parts?

Reply
0 Kudos
Highlighted
Level 6
276 276 27 46
Message 6 of 12
334
Flag Post
HP Recommended

Designjet 510 wont align

Try removing the printheads, close the printhead cover and latch it. Remove the paper. Disconnect the communication cable. Close the cover, unplug the power cord for about a minute. Plug the power cord back in, power ON the printer and allow it to power up. See if it still comes up with the error, or hopefully, it says it's missing printheads. If it asks for the printheads, proceed to install them and let it go from there and see what it does now. If it comes up Ready, load paper, try an internal print. If all that goes well, reconnect the communication cable. If you get a 79 error now, it's due to a bad print job being sent to the printer from the computer. Delete the print from the print queue in the computer.

Reply
0 Kudos
Highlighted
Level 2
11 10 1 3
Message 7 of 12
218
Flag Post
HP Recommended

Designjet 510 wont align

Yep... did all that .. the problem remains. Still won't calibrate colors or align.. 

 

I even did a full cleanup and lubrication of the service station just to make sure the docking wasn't giving some resistance feedback to the printer..

 

Whenever the print tries to align or to do a color calibration it just goes in and out of the service station 3 times and then cancels the procedure saying that one printhead is damaged (randomly on the frist two slots.. either cyan or black.. which are ok).. as if it was expecting something that never comes.. like a a sensor feedback or something..

 

Any ideas... should i start to test the trailing cables with a multimeter?

Reply
0 Kudos
Highlighted
Level 1
11 9 0 0
Message 8 of 12
205
Flag Post
HP Recommended

Designjet 510 wont align

Interesting.

While I had a problem that started as a "replace printhead 1", it did start the calibration process after what it said that printhead replacement wasn't complete etc.

However, after we did a bunch of stuff, it stopped trying to do the  preparation of the printheads and just cancels it.

 

It was then diagnosed with primer motor fail (part of service station), that was also confirmed by the test from diagnostics menu. Funny enough it did not failt the test a week ago when it was first done.

 

I'm now awaiting myself for a new servicing station (old one has a few other problems too), to see it that helps.

If it will, I'll have a look what happened to the original primer motor to see if its fixable but in the meantime, you can try running a diagnostic to see it this might be the case for you too.

Reply
0 Kudos
Highlighted
Level 2
11 10 1 3
Message 9 of 12
186
Flag Post
HP Recommended

Designjet 510 wont align

I went ahead and disassembled the service station motor.. it's a simple step motor.. does not seem to be damaged but I have resoldered the tracks just to make sure and tested the conductivity between pads.. all seems ok..

 

IMG_20200320_221007.jpg

I have noticed however under the carriage.. right into the light sensor used for color calibration a little scratch.. is normal or is there a flex under this that might have been damaged while I was printing of the canvas?

 

IMG_20200320_225424.jpg

 

Any ideas?? 🙂

Reply
0 Kudos
Highlighted
Level 1
11 9 0 0
Message 10 of 12
179
Flag Post
HP Recommended

Designjet 510 wont align

My primer motor works fine as far as I can tell, but it still fails the diagnostics. It or something in between or associated with it.

Error 22.1:10 or something liek that.

 

I can't see the prictures for some reason.

 

I'd asume your model can do primer motor diagnostics? Just to be sure it don't fail.

 

OK+ Up or down if I'm not mistaked while powering on  should get you to a service menu.

 

11111.PNG

 

Reply
0 Kudos
Be alert for scammers posting fake support phone numbers on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation