cancel
Showing results for 
Search instead for 
Did you mean: 
Freebird61
New member
1 0 0 0
Message 1 of 1
346
Flag Post

B&O Audio Sound issues after install of Ubuntu & Cinnamon Remix 20.04 in tri boot with windows 10

HP Recommended
HP Pavillion AIO 27 xa0xxx Desktop
Linux

ok Ive exhuasted about every option Ive been able to find so far to try and solve this problem from following many steps others have provided that have given some of them sound.I have no sound in either of my Ubuntu 20.04 installs...Focal Fossal or Ubuntu Cinnomon Remix 20.04...just the popping noise in the speakers. Windows 10 still has perfectsound . Im still a newb to linux can instal partition format use terminal format bootable iso usb stuff like that and anything in Windows...but this has me stumped.I know it has to be a kernel version and more than likely an Intel driver update for cannon lake  snd hda hdmi codec I havent been able to find and If I did I dont know how to update it and edit it into the right place!       this is what I got  in terminal about my audio info from  sudo apt commands....   ~$ lspci -v | grep -i audio
00:1f.3 Audio device: Intel Corporation Cannon Lake PCH cAVS (rev 10) (prog-if 80)
mark@hp-pavilion-aio-27xa0xxx:~$ lsmod | grep snd_hda_intel
snd_hda_intel 53248 5
snd_intel_dspcfg 24576 3 snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common
snd_hda_codec 131072 5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_core 90112 9 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hda,snd_sof_intel_hda
snd_pcm 106496 9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_core,snd_hda_core,snd_pcm_dmaengine
snd 90112 22 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm,snd_rawmidi
mark@hp-pavilion-aio-27xa0xxx:~$ lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation Cannon Lake PCH cAVS [8086:a348] (rev 10)
DeviceName: Onboard - Sound
Subsystem: Hewlett-Packard Company Cannon Lake PCH cAVS [103c:84ee]     I could be wrong in also thinking it has something to do with the generic driver...If anyone has any ideals or solutions as of July 3 2020.... I would apprieciate anything you might could offer me. Thanks and  to those in the US Happy 4 th to all...and  I Say Up the Covid19 A**!!!!

Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation