Post new question
Question
Reply
 
Highlighted
Top Student
Posts: 5
Member Since: ‎04-05-2017
Message 1 of 1 (86 Views)

HP EliteDesk 800 display and power issues

[ Edited ]
Product Name: EliteDesk 800 G2 SFF
Operating System: Microsoft Windows 10 (64-bit)

   We have 3 EliteDesk 800 G2 SFF PCs (so far) in 3 different environments that are having power and or blank video issues.   All 3 units were purchased in late 2016.  The first PC  we had issue with had a "Begin Date" of 9-14-2016.  When you pushed the power button, it showed there was power, but the screen was blank and the fans would not rev.  On that unit we did the BIOS update and the Intel Mgt firmware update and that "seems" to have fixed the issue as it's been a couple of months with no reoccurrence. 

   The second PC has a "Begin Date" of 3-29-2016 even though it was not purchased until Dec 2016.  It has issues where when you power it down, it doesn't really power off all the way or it will power off, but then will auto power back on.  Initially we also did the BIOS and firmware updates, but it did not fix the issue.  We also edited the registry to tell it to not auto reboot, but that did not help.  When you check the event logs, it just says that the unit has recovered from an unexpected shutdown.  We ran all the internal HP diagnostics and also the latest HP Vision Diagnostics which found no issues.  Figured the issue was probably either system board or power supply related.  Replaced the power supply, but the issue has reoccurred.

   The third PC we are just now looking at.  It also has a "Begin Date" of 3-29-2016, but again was only purchased within the last few months.  It is also experiencing a similar issue as the first PC where when you power it on, the screen is blank.  Sometimes the fans will rev, but no display.  If you just power it off and back on, that doesn't do it.  You have to pull the power plug and hold in the power button to drain any residual power.  One of the HP forums said to update the BIOS and Intel Mgt Driver, but to also update the video and chipset, too.  Some people on the forum said this helped and others said it made no difference.  I have done the updates, but have not put the unit back in service yet to actually test.

    I checked at HP and did some google searches.  I couldn't find anything conclusive, but is anyone else having these power/screen issues with this model?  As I said these are all in different environments with almost the same issue.   

Reply
0
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation