cancel
Showing results for 
Search instead for 
Did you mean: 
agangopa
Level 1
8 7 0 1
Message 1 of 16
854
Flag Post

HP Envy 750st Desktop won't power on

HP Recommended
Envy 750st
Microsoft Windows 10 (64-bit)

 

My two-year-old Envy 750st has suddenly stopped powering up. There is a green light flashing on the PSU. This is is what I have tried so far:

1. disconnected power and held the power switch for 30 seconds. No change.

2. Disconnected 24 pin cable from the motherboard, the PSU light changes to steady green.

3. Connected the green and black wires on the 24 pin cable with a paper clip and the PSU starts working with the fan coming on.

It seems that the problem is not the PSU and most likely the motherboard. If that is the case, it is probably not worth trying to repair it, even though the computer is only a little more than two-years-old, and I paid close to $1000 for it. Really disappointed with HP quality.

Is there anything I am missing? Could it be something simple like dead CMOS battery? I will appreciate any suggestion in this regard.

Thanks in advance.

15 REPLIES 15
Grzwacz
Level 12
Level 12
6,774 6,758 637 1,524
Message 2 of 16
Flag Post
HP Recommended

Hi,

 

A faulty PSU can provide current but not the correct amperage to power on the system.

 

You will have to swap components to find the the cause.

 

Try starting the system by disconnecting all unnecessary internals and peripherals. Just RAM, CPU, and a monitor.

 

Pull the discrete GPU and use onboard graphics if possible. I can't find an HP product using 750st. I don't know what you have.

 

It would not hurt to replace the CR2032 MB battery. Can't say this is the fix.

 

Regards

 

 

0 Kudos
agangopa
Author
Level 1
8 7 0 1
Message 3 of 16
Flag Post
HP Recommended

Thank you for your reply.  I appreciate it.  I ordered the desktop directly from HP website, it was custom made and shipped to me.  I guess that is the reason you didn't find it on the HP website.

 

I think it does have onboard Intel graphics, so I can certainly try your suggestion later today, and get back here with the result.

 

Thanks again.

0 Kudos
Grzwacz
Level 12
Level 12
6,774 6,758 637 1,524
Message 4 of 16
Flag Post
HP Recommended

Hi Agangopa,

 

You're very welcome.

 

Good luck.

 

Regards

0 Kudos
agangopa
Author
Level 1
8 7 0 1
Message 5 of 16
Flag Post
HP Recommended

So here is the update on my problem:

1.  I was wrong about the model number.  The exact model number is HP 750-280st.

2.  Changed the CMOS battery.  Didn't help.

3.  Unfortunately, it seems that there is no onboard graphics.  There are HDMI outlets on the case, but these are sealed off.  Thus, I wasn't able to remove the graphics card.  I tried disconnecting on the extra (non-OS HD) and the optical drive, but that didn't help either.

One question: If this is a motherboard issue, shouldn't the computer be beeping to provide error codes?

 

I guess I can try to get a new PSU and see if that helps.  Anything else I should try before I do that?

 

Thanks in advance.

0 Kudos
Grzwacz
Level 12
Level 12
6,774 6,758 637 1,524
Message 6 of 16
Flag Post
HP Recommended

Hi,

 

You would not get error codes if the motherboard (MB) has failed or the PSU is failing.

 

I think you stated earlier the PSU fan would spin when you jumpered the 24 pin PSU connector. 

 

Do you see any signs of life on the MB (LEDs) or CPU/chassis fans when trying to power on your PC?

 

I would try a different PSU if possible.

 

No change in symptoms probably means the MB is toast.

 

Regards

0 Kudos
agangopa
Author
Level 1
8 7 0 1
Message 7 of 16
Flag Post
HP Recommended

There is no light on the Motherboard.  I am wondering about that too.  Perhaps this motherboard has no light, if that is possible.

 

The CPU fan does not run and there is no sign of life on the Motherboard.

 

I guess the only thing for me to try is to get a PSU and see if anything changes.  I will give HP a call to see how much they charge for repairs.  Most likely it won't be worth it.

 

Thanks again.

0 Kudos
Grzwacz
Level 12
Level 12
6,774 6,758 637 1,524
Message 8 of 16
Flag Post
HP Recommended

Hi.

 

You're very welcome.

 

Touch base with HP if a different PSU does not help. The PC should have a standard 300 watt or 500 watt ATX PSU. 

 

The PSU dimensions should be about 150 mm width, 86 mm height, and typically 140 mm depth. Or 5.9 inches, 3.9 inches, 5.5 inches respectively.

 

I would probably look for a reputable local PC tech if you are not in warranty.

 

Regards

0 Kudos
Grzwacz
Level 12
Level 12
6,774 6,758 637 1,524
Message 9 of 16
Flag Post
HP Recommended

Hi,

 

Forgot to mention you should have an Intel 6000 series processor with integrated graphics.

 

You should be able to try onboard graphics by using one of two HDMI ports on the rear I/O shield.

 

Did HP permanently seal the HDMI ports? That is strange.

 

I-O.PNG

 

Regards

0 Kudos
agangopa
Author
Level 1
8 7 0 1
Message 10 of 16
Flag Post
HP Recommended

You are right!   The two HDMI ports are covered with some black caps that are extremely tight, so I assumed that these are sealed.   Later today I will try removing the video card and see if that helps. There is a 600W PSU on sale at  Bestbuy that has the same dimension you mentioned.  I will get that as well.

 

 One question:  This computer uses DDR4 RAM (2X8GB in banks 1 and 3) and I don't have any extra lying around.  Can I test if any of the RAMs is defective by taking out one at a time, or do I need to have both RAMs installed for the motherboard to start?

 

Again, very much appreciate your willingness to help.

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation