cancel
Showing results for 
Search instead for 
Did you mean: 
rpw0563
Level 1
2 1 1 0
Message 1 of 2
423
Flag Post

Solved!

The preboot authentication application cannot be found

HP Recommended
Elitedesk 800 g1 DM
Microsoft Windows 10 (64-bit)

Been struggling with this error message...tried just about everything...I get this message only during the cold boot of an Elitedesk 800 G1 DM. It was a former corporate device, it had no hard drive so I imaged a new drive with the actual Win10 HP image. Everything works great except for this message. I thought maybe it was the TPM causing it, so I wiped it and turned it off. No difference. I've tried every possible BIOS setting, no effect. I'm stuck, and internet searches don't come up with much.   Looking for assistance from the HP community...has anyone else run into this error message, and if so, how did you correct it?

1 ACCEPTED SOLUTION

Accepted Solutions
rpw0563
Author
Level 1
2 1 1 0
Message 2 of 2
Flag Post
HP Recommended

Finally solved this. It wasn't easy, but here are the steps I took (disclaimer: perhaps all these steps are not needed, but I like to use the shotgun approach, and these worked for me)...

 

After reading through (and between the lines of) the HP documents on Pre-Boot Authentication, I realized that HP was leveraging the UEFI protocol to set some pre-boot options using the Windows 10 OS. Due to HP not providing any documentation on the inner workings of their security (nor should they), I had to make some educated guesses as to what was going on. Since I had purchased the HP Elitdesk without a hard drive, I also guessed that the prior owner had flipped on one or more HP security features within the OS (of which only Windows is officially supported) and never turned them off before the device was retired from service.

 

I started by installing the latest version of Windows and the latest version of the HP Client Security Management (CSM) application. I flipped the security settings on, rebooted, flipped them off, nothing. Since this didn't do anything, I decided to return the device to as close to original factory settings as I could, so here's what I did:

 

- downloaded HP Windows 10 version 1511 to a USB device using the HP Cloud Recovery Application. I used the serial number from the HP device and the model name "Prodesk 400 G1 DM" to get version 1511.
- I then copied the image from this USB device to another USB device using Rufus, and indicated I wanted to format a GPT drive (a drive needs to be GPT formatted to be recognized by the UEFI boot process).
- Next I set the bios options on the device to UEFI (NOT Legacy) and made sure the TPM (security device) was on.
- I then proceeded to clean install HP Windows 10 version 1511 on the hard drive, leaving the password blank.
- Once the install was complete, I then installed the HP CSM version SP74101.exe and re-booted. This older version has more options than the newer ones. Interesting. It also supports HP Drive Encryption, which is no longer supported in newer versions of Windows 10.
- Next, I installed HP Drive Encryption (version SP71555.exe) and re-booted.
- I then launched the HP CSM, which forced me to provide a Windows password. I then turned on "Windows Logon Security" and "Allow One-Step Logon". "Pre-Boot Security" (Power-on authentication) was not listed as an option, but if it does, turn it on.
- Next, I encrypted the Hard Drive using the HP Drive Encryption function located in the CSM. I don't know if this step is needed, but I did it anyway. Again, shotgun approach. Once that was complete, I did a cold re-boot. The message was gone. cool.Now try to make it go away forever.
- I then decrypted the Hard Drive. Once that was complete, I cold re-booted. Message still gone. Once back in the OS, I switched off all the HP security setting I had flipped on previously, and then cold re-booted. Message still gone!
- Now it was time to get serious. I deleted the HP Drive Encryption and re-booted. Then I delete the HP CSM and re-booted. Message still gone.
- I then went back into the bios, turned Legacy on and disabled the TPM (Security device). Re-booted. Cold re-booted multiple times, and the message is gone.

 

I then proceeded to install Ubuntu and am now using the device as an appliance that will start on it's own after a power outage (rather than stopping at that stupid message and requiring someone to touch it to get it going again).

View solution in original post

0 Kudos
1 REPLY 1
rpw0563
Author
Level 1
2 1 1 0
Message 2 of 2
Flag Post
HP Recommended

Finally solved this. It wasn't easy, but here are the steps I took (disclaimer: perhaps all these steps are not needed, but I like to use the shotgun approach, and these worked for me)...

 

After reading through (and between the lines of) the HP documents on Pre-Boot Authentication, I realized that HP was leveraging the UEFI protocol to set some pre-boot options using the Windows 10 OS. Due to HP not providing any documentation on the inner workings of their security (nor should they), I had to make some educated guesses as to what was going on. Since I had purchased the HP Elitdesk without a hard drive, I also guessed that the prior owner had flipped on one or more HP security features within the OS (of which only Windows is officially supported) and never turned them off before the device was retired from service.

 

I started by installing the latest version of Windows and the latest version of the HP Client Security Management (CSM) application. I flipped the security settings on, rebooted, flipped them off, nothing. Since this didn't do anything, I decided to return the device to as close to original factory settings as I could, so here's what I did:

 

- downloaded HP Windows 10 version 1511 to a USB device using the HP Cloud Recovery Application. I used the serial number from the HP device and the model name "Prodesk 400 G1 DM" to get version 1511.
- I then copied the image from this USB device to another USB device using Rufus, and indicated I wanted to format a GPT drive (a drive needs to be GPT formatted to be recognized by the UEFI boot process).
- Next I set the bios options on the device to UEFI (NOT Legacy) and made sure the TPM (security device) was on.
- I then proceeded to clean install HP Windows 10 version 1511 on the hard drive, leaving the password blank.
- Once the install was complete, I then installed the HP CSM version SP74101.exe and re-booted. This older version has more options than the newer ones. Interesting. It also supports HP Drive Encryption, which is no longer supported in newer versions of Windows 10.
- Next, I installed HP Drive Encryption (version SP71555.exe) and re-booted.
- I then launched the HP CSM, which forced me to provide a Windows password. I then turned on "Windows Logon Security" and "Allow One-Step Logon". "Pre-Boot Security" (Power-on authentication) was not listed as an option, but if it does, turn it on.
- Next, I encrypted the Hard Drive using the HP Drive Encryption function located in the CSM. I don't know if this step is needed, but I did it anyway. Again, shotgun approach. Once that was complete, I did a cold re-boot. The message was gone. cool.Now try to make it go away forever.
- I then decrypted the Hard Drive. Once that was complete, I cold re-booted. Message still gone. Once back in the OS, I switched off all the HP security setting I had flipped on previously, and then cold re-booted. Message still gone!
- Now it was time to get serious. I deleted the HP Drive Encryption and re-booted. Then I delete the HP CSM and re-booted. Message still gone.
- I then went back into the bios, turned Legacy on and disabled the TPM (Security device). Re-booted. Cold re-booted multiple times, and the message is gone.

 

I then proceeded to install Ubuntu and am now using the device as an appliance that will start on it's own after a power outage (rather than stopping at that stupid message and requiring someone to touch it to get it going again).

View solution in original post

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation