cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
camiimperato
New member
1 0 0 0
Message 1 of 3
529
Flag Post

Ethernet doesn't have valid IP configuration when using built in Modem in computer.

HP Recommended
Pavilion Slimline
Microsoft Windows 10 (64-bit)

We have been using the wireless router with a built in modem from our internet provider which continues to work great.  When trying to install our new Linksys router through the built in Modem in this computer, the error code 651 comes up and is unable to establish a connection to the network.  Troublshooter says "Ethernet doesn't have valid IP configurations".  I have tried several things to update drivers, etc. and the problem persists.  

Thank you

0 Kudos
2 REPLIES 2
old_geekster
Level 16
Level 16
24,583 24,235 2,826 10,341
Message 2 of 3
Flag Post
HP Recommended

@camiimperato, welcome to the forum.

 

When requesting help you should always include the make/model (i.e. p6-xxxx) of the computer and/or monitor. This information is necessary for us to review the specifications of them.






I am not an HP Employee!!

Intelligence is God given. Wisdom is the sum of our mistakes!!
0 Kudos
davidsergel9
New member
1 1 0 0
Message 3 of 3
Flag Post
HP Recommended

I have faced this issue a few times before on my Windows 10 computer and after resetting IP configuration with the following command:

 

- netsh ip reset

 

and then set the static IP settings again.

 

It's resolved!

 

https://usefulpcguide.com/18773/fix-ethernet-doesnt-have-a-valid-ip-configuration-error-in-windows/


@camiimperato wrote:

We have been using the wireless router with a built in modem from our internet provider which continues to work great.  When trying to install our new Linksys router through the built in Modem in this computer, the error code 651 comes up and is unable to establish a connection to the network.  Troublshooter says "Ethernet doesn't have valid IP configurations".  I have tried several things to update drivers, etc. and the problem persists.  

Thank you


 

0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation