Note on archived topics.

This topic has been archived. Information and links in this thread may no longer be available or relevant.
If you have a question create a new topic by clicking here and select the appropriate board.
lastwraith Tutor
Tutor
11 0 6
Message 1 of 1
361
Flag Post
HP Recommended

UEFI settings to disable secure boot do not stick, they revert back after reboot

EliteOne 800 G2 AIO
Microsoft Windows 10 (64-bit)

This is not really a question. I wrestled with this problem at a client site and wanted to share our findings with the community since I don't see the actual solution posted in an obvious place online and even HP support took a long time to help figure out the issue. Latest UEFI "BIOS" file at time of writing (6/11/2016) does not help either.

 

My suggestion to HP would be to encode a clear INPUT FAILURE message when the 4 digit code has been rejected instead of what currently happens - the PC plays a tune and it seems like all is well but then you get the boot error listed below.

 

Prob
On an HP with UEFI, settings revert back when trying to disable secure boot
Error msg - Selected boot image did not authenticate
 
Cause
NUMLock not being ON when system prompts for 4 digit code upon boot (causing code to be rejected)
and/or
Fast boot is ENABLED
 
Solution
1 - DISABLE Fast Boot
AND
2 - Either use the number keys or hit NUMLock and THEN use number pad

HP should show numbers entered, "sing" some audio, and then UEFI settings should stick

 

*Remember that a USB stick must be formatted Fat32 to show as a boot option in UEFI unless you enable legacy boot options (assuming they are available)

0 Kudos

Note on archived topics.

This topic has been archived. Information and links in this thread may no longer be available or relevant.
If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation