Ask questions. Help others.
The HP Community is here for you.
Post new question
Question
Reply
 
Note on archived topics.
This topic has been archived. Information and links in this thread may no longer be available or relevant.
If you have a question create a new topic by clicking here, or click on "Post new question" above and select the appropriate board.
Intern
Posts: 34
Member Since: ‎03-08-2010
Message 1 of 18 (5,033 Views)
Accepted Solution

XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

[ Edited ]

I ordered my birthday present, an XFX Radeon 5770 1GB DDR5 HD Graphics Card http://www.hardwarecanucks.com/forum/hardware-canucks-reviews/24204-xfx-radeon-hd-5770-1gb-gddr5-rev...
This is the second delivery as the first one was duff. Well so is this one, or is it me?

My comp has only one PCI-EX16 slot and this card is PCI-E2 supposedly compatable.
I installed a new PSU from 300w to 650w and it also supplies many new plugs one of which is a 6pin 75 plug.

After installation, I get a black screen, the card is running as I can see the fan running, but there is no power to either of my monitors, one is 22" and the other is 17"...

I am running a Core2Duo 2.6 processor E6600 and 4GB ram, I have 1.7TB disk space and all have ample room for page file etc.

I run Windows Vista Home Premium and have 32bit vers.

here is my Mobo http://support.hp.com/us-en/document/c00864946

I have installed the card like the instruction say, I have installed the new drivers, uninstalled the old drivers, I have done more installing and uninstalling it's beyond belief, I have no friends to try on their computer and only one PCI-E slot on my own so I have only all of UKMD to ask as my local shop wants 30quid and 3 days with my comp just to work it out, sod that!

HELLLLP!

0 Kudos
Accepted Solution

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

Oh man, I went through it again yesterday didn't I? I thought to myself, if I could make a GeForce card work why settle for the 512 when for 10pounds more I could have a 1GB?

 

I arranged for the Radeon card to be collected, uninstalled the new nVidia card, took it back and bought this card, the ZOTAC GeForce® GTS 250 Eco 1GB and brought it home, and nothing, no bloody screen so I thought there is one last thing I never tried before. On the back of my comp there is a small black plate that says “Do Not Remove” well removed it and there was a VGA port, A BLOOODY VGA PORT!!!!!

I put my old card back in>fired up my comp> switched to onbard graphics> turned on my comp (mind you I have two monitors) so this would not have been successful without two> so I powered down, installed the new card> powered up> installed the card with the onboard still working>installed the drivers but, Error> “there is a problem.....yadda yadda yadda, VGA not compatible” HMM

SO VGA means the onboard, so I powered down, turn off the onboard graphics and VOILA!!!!!!!!!

I am now a working graphics card owner STUPID STUPID STUPID!!!

If I had done this in the very beginning I would be running DDR5 and DX11 - maybe

so as a Sadist, do I try this system with the Radeon card?!?! NO

I am going to leave it lol if I had the 1GB card here I would so, happy happy joy joy Smiley Very Happy

 

my Zotec card is amazing and after over 9000 forums and help pages, I myself have sorted it out Smiley Very Happy

 

I am posting this as it is important to know there are work arounds for even the most seemingly difficult impossible problem...

 

View solution in context
Provost
Posts: 26,674
Member Since: ‎07-17-2009
Message 2 of 18 (5,031 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

[ Edited ]

Boot into the bios (setup) and look to see if the bios recognizes your 5770.  You might have to set your video to PCI-E x16 and/or disable the onboard video.  Only use one monitor until you get the card working.  Then go to ATI and get the latest driver update.

HP laptop 17t u100,
HP Photosmart 6520 and HP Deskjet 1112
Custom 1151 socket Z270 Intel i7-7700k @4,600 Mhz, 16GB Corsair 3000 Mhz dimms
Corsair H75 water cooler, Corsair CS 650M power supply
RAID 0 (dual Samsung 960 EVO m.2 240GB) boot system
Dual Samsung 840 EVO SSDs 500GB data storage, Intel 750 PCIe SSD 400GB
MSI NVIDIA GTX 980TI 6GB
ASUS ROG PG279q @144 MHz
Windows 10 and Windows 8.1 Pro x64 in UEFI mode
Intern
Posts: 34
Member Since: ‎03-08-2010
Message 3 of 18 (5,028 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

I can't see anything when I boot up with the new card as I have no screen. When I plug in my monitor to the new card and turn on my machine, it's as if I have unplugged my monitor all together. so, to get into my bios, I have to take out the new card and replace it with the ATI Radeon X1650ES my comp came with.

 

Someone mentioned that my PCI-EX16 is not accepting the PCI-E2 card or something.

 

He said "I had a look over the spec you linked to for your motherboard and it did not state that the PCI-e x16 port was ver2 so that could be your problem."

 

Is this a possibility, is this something fixable? or...

Intern
Posts: 34
Member Since: ‎03-08-2010
Message 4 of 18 (5,027 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

also I am on GMT time so I'm off to bed, will get back on this in a few hours

 

Cheers for helping me Smiley Very Happy

Provost
Posts: 26,674
Member Since: ‎07-17-2009
Message 5 of 18 (5,020 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

[ Edited ]

Boot up into the bios (setup) with the old card installed and see what options for video are selectable.

 

You might try installing the new card then clear the CMOS and boot up.

HP laptop 17t u100,
HP Photosmart 6520 and HP Deskjet 1112
Custom 1151 socket Z270 Intel i7-7700k @4,600 Mhz, 16GB Corsair 3000 Mhz dimms
Corsair H75 water cooler, Corsair CS 650M power supply
RAID 0 (dual Samsung 960 EVO m.2 240GB) boot system
Dual Samsung 840 EVO SSDs 500GB data storage, Intel 750 PCIe SSD 400GB
MSI NVIDIA GTX 980TI 6GB
ASUS ROG PG279q @144 MHz
Windows 10 and Windows 8.1 Pro x64 in UEFI mode
Intern
Posts: 34
Member Since: ‎03-08-2010
Message 6 of 18 (4,994 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

Hi and thanks for your help, I don't think i know how to clear the CMOS...

 

I have gone into the BIOS and the choices are, PCI / PCI-E / Onboard

 

the PCI was selected and I switched it to PCI-E but still nothing

 

will google CMOS and see if I can find anything out

Intern
Posts: 34
Member Since: ‎03-08-2010
Message 7 of 18 (4,989 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

ok so i looked into it, my motherboard link helps with the jumper thing, but the BIOS setup (f10) did not look fruitful.

 

So I switched the jumper waited like 20 seconds to be sure, then put it back to the setting it was on> restarted> changed the PC~I to PCI-E on adaptors and left everything else as I wasn't sure>started up to the password screen> switched off> installed new card> Switched on> nothing... same result no screen at all nothing, nada 

 

I think I'm doing everything right but am not sure...

Intern
Posts: 34
Member Since: ‎03-08-2010
Message 8 of 18 (4,970 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

Hi again,

 

I've just updated my BIOS and will now install the new card and clear the CMOS at the same time and see what happens...

 

Back soon!

Intern
Posts: 34
Member Since: ‎03-08-2010
Message 9 of 18 (4,968 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

sadly nothing had worked, I don't have a clue what to do next...

 

Monday the XFX helpdesk is open as is DABS where I got the card from here in the UK.

 

other than that, enjoy the fact that my current card is not faulty Smiley Very Happy *knocks wood*

Intern
Posts: 34
Member Since: ‎03-08-2010
Message 10 of 18 (4,924 Views)

Re: XFX Radeon 5770 1GB DDR5 HD Graphics Card failure

I found this on the web over the weekend Smiley Sad

 

http://vip.asus.com/forum/view.aspx?board_id=1&model=P5L+1394&id=20091227032601437&page=1&SLanguage=...

 

that is a forum with some answers, but nothing good I'm afraid... here's the original letter 

 

----------------------------------------------------

 Posted:12/27/2009 5:45:00 AM1
Hello,

I have an HP Pavilion m8079.fr :
- motherboard  Asus P5LP-LE (called LEONITE by HP/Compaq)
- chipset Intel i945G

NB: P5LP-LE (or LEONITE) does not appear into the motherboard model list.

Changed Power supply to Corsair TX650w : ok

Changed graphic card to ATI Radeon HD 5770 msi (1 Gb) :
- no video ouput
- no beep,
- all fans (Power, case, and graphic card) ok
- Windows do not start (I do not heard the HD)
NB: this graphic card works well on another PC.

Updated BIOS to latest revision 5.23 (with HP tool).
Changed graphic card to ATI Radeon HD 5770 sapphire (1 Gb) : nothing new

Another person has the same problem (same motherboard) with ATI Radeon HD 5770 XFX (1 Gb), and XFX finally said that this motherboard does not accept the 1Gb.

 

Any idea on this problem ?


Thanks,

Olivier

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation