cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
1dave1
Level 1
12 7 0 0
Message 1 of 2
210
Flag Post

envy 750-414 HDD not shown

HP Recommended
envy 750-414
Microsoft Windows 10 (64-bit)

I have a new envy 750-414 Win 10, with a SSD (C:) and a DHH (D:).

 

C:\ drive is working ok. But, drive D is not shown in the file tree in explorer. It (D:) is in Device Mngr>Disk drives, shown as a Western Digitial model number. Right clicking on it > Properties says 'device is working properly'. Device Mngr>Portable Devices also lists D:\, rightclicking on it>Properties says 'device is working properly'.

It is also under Disk Mngmt as Disk 1 (D:) and says 'Healthy (Primary Partition)' and zero bits used.

 

Why does the pc know D drive is there, but not show it in the file explorer so it can be accessed?

What is the fix for it ?

 

thx dave

0 Kudos
1 REPLY 1
1dave1
Author
Level 1
12 7 0 0
Message 2 of 2
Flag Post
HP Recommended

I want to also mention I went to Western Digitial website, got their diagnosic tool, did their extended test - took 2 hrs - and the drive 'passed'. So, I'm pretty sure there is nothing wrong and the drive is working fine.

 

dave

0 Kudos
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation