Ask questions. Help others.
The HP Community is here for you.
Post new question
Question
Reply
 
Note on archived topics.
This topic has been archived. Information and links in this thread may no longer be available or relevant.
If you have a question create a new topic by clicking here, or click on "Post new question" above and select the appropriate board.
Honor Student
Posts: 2
Member Since: ‎01-25-2010
Message 1 of 3 (1,387 Views)

high CPU usage on Windows 7

I have searched the forums and the internet and even contacted Microsoft customer support but cannot find any help.  I upgraded my Pavillion a6720y from Vista 64-bit to Windows 7 64-bit Home Premium a couple of months ago.  I guess I was the only person that never encountered a problem with Vista so I was expecting a smooth transition to Windows 7.  The problem that I am experiencing with my HP desktop is very high CPU usage after some random period of low usage after it is first turned on.  The CPU usage goes from a few percent to high 80’s to mid 90’s and everything slows down to a crawl.  This random period can go from minutes to days.  Shutting the system completely down works most of the time.   When checking Task Manager, no processes indicate high usage at all with processes running less than a few percentages after an initial spike after starting a program.  When I check “Show processes from all users”, the only high CPU usage is with System Idle Process and nothing else.  I’ve redone the upgrade couple of times and then finally bit the bullet and did a clean install, but nothing helps.  I’ve kept track of the Processes and the Services in Task Manager that are running when it is in low CPU usage and after it goes into high CPU usage and nothing changes.  I’ve tried too many things on my own to mention here, but would appreciate any suggestions anyone might have.  My hardware specs are as follows:

0 Kudos
Provost
Posts: 26,710
Member Since: ‎07-17-2009
Message 2 of 3 (1,374 Views)

Re: high CPU usage on Windows 7

Try this article:

http://social.answers.microsoft.com/Forums/en-US/w7performance/thread/b5c79a15-781b-455a-9003-6d3056...

HP laptop 17t u100,
HP Photosmart 6520 and HP Deskjet 1112
Custom 1151 socket Z270 Intel i7-7700k @4,600 Mhz, 16GB Corsair 3000 Mhz dimms
Corsair H75 water cooler, Corsair CS 650M power supply
RAID 0 (dual Samsung 960 EVO m.2 240GB) boot system
Dual Samsung 840 EVO SSDs 500GB data storage, Intel 750 PCIe SSD 400GB
MSI NVIDIA GTX 980TI 6GB
ASUS ROG PG279q @144 MHz
Windows 10 and Windows 8.1 Pro x64 in UEFI mode
Honor Student
Posts: 2
Member Since: ‎01-25-2010
Message 3 of 3 (1,354 Views)

Re: high CPU usage on Windows 7

Thanks Big Dave.  I had already found that, but I did find the solution here on the HP site at ftp://ftp.hp.com/pub/softlib/software11/COL31608/pv-78469-1/sp44620.exe 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation