cancel
Showing results for 
Search instead for 
Did you mean: 
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
nugpie
New member
2 0 0 0
Message 1 of 2
447
Flag Post

z230 won't power up

HP Recommended

I have used different power cords, different sockets, no power strip.  I tried the "hold pwer button down for 10 seconds" trick  No power at all. 

1 REPLY 1
Brian1965
Level 7
537 515 73 128
Message 2 of 2
Flag Post
HP Recommended

Hi nugpie,

 

Have you tried removing the side cover and reseating the connectors? Give everything a quick inspection while you're there, including the cables ends for the front panel? If that doesn't work, and you've tried different cables, etc., then it sounds like it could be the power supply.

HP Z620 - Liquid Cooled E5-1680v2 @4.7GHz / 64GB Hynix PC3-14900R 1866MHz / GTX1080Ti FE 11GB / Quadro P2000 5GB / Samsung 256GB PCIe M.2 256GB AHCI / Passmark 9.0 Rating = 7147 / CPU 17461 / 2D 1019 / 3D 14464 / Mem 3153 / Disk 15451 / Single Threaded 2551
Was this reply helpful? Yes No
ArchivedThis topic has been archived. Information and links in this thread may no longer be available or relevant. If you have a question create a new topic by clicking here and select the appropriate board.
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation