• ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
  • ×
    Information
    Windows update impacting certain printer icons and names. Microsoft is working on a solution.
    Click here to learn more
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.
    Windows 11 Support Center.
  • post a message
Guidelines
The HP Community is where owners of HP products, like you, volunteer to help each other find solutions.
HP Recommended
Hp Soectre x360 Convertible
Microsoft Windows 10 (64-bit)
Omen Accelerator GA1-10
Microsoft Windows 10 (64-Bit)
 

My Omen Accelerator has stopped working and is behaving strangely. It has not managed to connect to my laptop. The standby lights come on as normal, once plugged in to my laptop the active lights come on, but it does not get detected by my laptop in the Omen Accelerator App or in the Intel Thunderbolt Software. My laptop does charge. Once I disconnect the thunderbolt cable from my laptop the active lights stay on, as if it hasn't detected the disconnection, and stays like that until I pull the power cable and put it back in, or until I press the reset button.

I have ruled it out as a software issue by restarting my laptop and reinstalling all set up software via following the provided set up instructions again. For hardware I have tried putting in a different GPU, a different power supply, a different power cable, a different thunderbolt 3 cable, unplugging everything except power and my laptop, pressed the reset button for short and long periods of time both with power on and off, and took it apart and cleaned everything before reassembling.

1 REPLY 1
HP Recommended

@Ac212
Thank you for posting on the HP Support Community.

 

I appreciate your efforts to try and resolve the issue. This sounds like a hardware related issue,

I would request you to reach out to our Support and our Support Engineers should be able to check the available service options in order to diagnose the device physically. HP Support can be reached by clicking on the following link:  www.hp.com/contacthp/​​​​​​​


Please feel free to contact us here anytime you need any further assistance. Please click “Accept as Solution” if you feel my post solved your issue, it will help others find the solution.

ECHO_LAKE
I am an HP Employee

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.