cancel
Showing results for 
Search instead for 
Did you mean: 
FattysGoneWild
Level 7
764 650 20 118
Message 1 of 9
2,443
Flag Post

Solved!

Omen command center update wont download

HP Recommended
Omen 880-160se
Microsoft Windows 10 (64-bit)

Says I don't have HP support assist installed so it wont download. That is certainly not the case as its installed. Picture attached. Inkedomenupdate_LI.jpg

8 REPLIES 8
Photoray002
Level 15
Level 15
12,364 12,152 1,269 3,963
Message 2 of 9
Flag Post
HP Recommended

What version of the OCC is that? 

Looks like the really old version prior to the Windows app.

 

I would uninstall it and grab the latest from the MS link...

Get OMEN Command Center - Microsoft Store

 

Create a restore point before that if you want to play it safe first.

0 Kudos
FattysGoneWild
Author
Level 7
764 650 20 118
Message 3 of 9
Flag Post
HP Recommended

Done what you said to do. Ended up with no overclocking options using the app from MS store. Uninstalled. Then reinstalled other version that came with my pc. Then reinstalled MS App Store version. Overclocking options came back. It also has intelligent mode for automatic overclocking. Running it now and says it can take up to 60 minutes.

0 Kudos
Photoray002
Level 15
Level 15
12,364 12,152 1,269 3,963
Message 4 of 9
Flag Post
HP Recommended

OK, so you have kept the old version all this time.

When you upgrade to the MS app and its giving your an odd reaction like that, then you probably need to run Windows updates manually and force it to search for updates, even if it shows its up to date. In other words, click on the Check for Updates button and make it update. Do it a couple of times. It has to install an HP HID file.

If you have overclocking ability with your Omen, the new app will give that to you too.

 

What version number does the OCC show in the bottom left corner?

Should be version 8.2.11.0 at the time i write this.

Edit, if you reinstalled the old version, but you have intelligent overclocking now. you have the new version obviously.

You might have to skip Intelligent Overclocking and go manual as you did before. Intelligent OC gave me problems and was not stable.

OCC update.JPG

0 Kudos
FattysGoneWild
Author
Level 7
764 650 20 118
Message 5 of 9
Flag Post
HP Recommended

Tried again what you suggested. It wont give me the options on the newer app unless the old one is installed as well. Running windows update many times did not pull any thing down. Pictures attached. Btw. The auto tuning clocked my cpu @5GHz, cache ratio 47 and voltage at default. I went back to defaults because I know that is not going to be stable in any way. I have the i7 8700k.

 

Capture1.JPGCapture2.JPGCapture3.JPG

0 Kudos
Photoray002
Level 15
Level 15
12,364 12,152 1,269 3,963
Message 6 of 9
Flag Post
HP Recommended

The middle image you posted of the intel sdk package being uninstalled error. Where is that coming from?

 

The OCC should run on that 880-160se just fine without the old version. It did on mine.

Did you also try installing the OMEN Command Center SDK Package ...  sp95690.exe ?

Install that, then the OCC and then open Services and scroll down to... HP Omen HSA Service and make sure its set to Running Automatic.

 

IF that doesn't work, I'm not sure what weird thing is happening on your system.

But If it works with the old one installed, I guess it wont hurt anything.

 

 

FattysGoneWild
Author
Level 7
764 650 20 118
Message 7 of 9
Flag Post
HP Recommended

Middle picture was from during reinstall of older version. I followed through on what you said to try next and it worked PERFECTLY! I tip my hat to you good sir!!! Thank you..... Btw, what kind of overclock did you get on the 8700k with this machine? Did the voltage slider actually work for you?

0 Kudos
Photoray002
Level 15
Level 15
12,364 12,152 1,269 3,963
Message 8 of 9
Flag Post
HP Recommended

whew, glad that worked out.

 

I didn't try on the new version. The old version the voltage slider didn't do anything.

I couldn't get past 4.7 stable.

 

Edit, typo

0 Kudos
FattysGoneWild
Author
Level 7
764 650 20 118
Message 9 of 9
Flag Post
HP Recommended

Yes I remember the voltage slider not working. I even complained to HP/Omen about it. I gave up even trying to overclock because of it. If I had to guess I have a feeling it’s the same thing. I found it funny auto tuning did not adjust voltage for that 5GHz and left it at default.

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation