cancel
Showing results for 
Search instead for 
Did you mean: 
Cornpopster
New member
1 0 0 0
Message 1 of 2
163
Flag Post

PC not turning on with new PSU

HP Recommended
OMEN by HP Obelisk Desktop 875-0014
Microsoft Windows 10 (64-bit)

I bought a new 650w psu to upgrade the 500w one that came with my Omen because of a 2080 super I bought recently. I'm able to jump the psu just fine with a bridge tool but it just refuses to turn on when connected to my pc. I put the old psu back into it and it works just fine. I noticed that the 24 pin connector has 2 missing pins while the psu I bought only has one missing. Does the motherboard use some sort of proprietary psu or is my new one defective?

1 REPLY 1
old_geekster
Level 16
Level 16
25,030 24,681 2,884 10,679
Message 2 of 2
Flag Post
HP Recommended

@Cornpopster , welcome to the forum.

 

I suggest that you test the new PSU to assure that it was not DOA.  I bought a PSU some years ago and could not get my computer to run.  I found out that the new PSU was DOA.   I don't believe that the PSU in your computer is proprietary.






I am not an HP Employee!!

Intelligence is God given. Wisdom is the sum of our mistakes!!
0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation