cancel
Showing results for 
Search instead for 
Did you mean: 
Jsmith6
New member
3 1 0 0
Message 1 of 2
818
Flag Post

HP Omen 17t Shutdowns in heavy load

HP Recommended
Omen 17t - RTX 2080 Super 150w
Microsoft Windows 10 (64-bit)

Dear community,

I purchased an HP Omen 17t with the following specs:

i7 10750h - RTX 2080 Super 150w

300hz g-sync certified - Win 10 Pro

512GB Samsung SSD + 1TB 7200rpm HDD

Charger: 330w charger by Omen

I setup the computer, updated all drivers and windows to the latest version, and updated bios from f.05 to f.12.

idle temps: cpu 45-55c (sometimes spikes to 70-80c) gpu 40-50c

I downloaded few heavy title games like Red Dead Redemption 2 and Control. Installed CSGO and PCSX2 for ps2 games emulation.

Whenever I run any game, after the games loading finishes, laptop shutdowns immediately without any error or blue screen.

When I run PCSX2 and load a ps2 game, second monitor connected to laptop gets black and has no signal but still detected by Windows. And after playing for like 2-3 minutes shutdown happens.

I always run these games when its plugged in.

I downloaded hardware monitor, msi afterburner and throttle stop. Disabled turbo boost, set PL1 and PL2 to 35 watts, and locked the gpu on 1st spot of clock curve (1300mhz - 700mv). I could play a csgo match but once the games finished and I tried to exit, blue screen happened and shutdown immediately. Tried red dead redemption with same options, could run the game but it was laggy (CPU usage ~15w + GPU usage 85-90w). During the game session, I tried to unleash the GPU voltage and clock on its normal curve (1500mhz + 770mv) (CPU usage ~15w + GPU usage 130w) and after like 5 seconds blue screen and immediate shutdown happens.

GPU temps was like 65-70c and CPU 85-90c before shutdown.

tried cinebench R20 with default CPU options (turboboost on + PL1 45w PL2 107w) laptop shutdown immediately.

tried different version of nVidia driver, performed a clean windows installation two times and each time laptop shutdown happened during windows installation so I had to start the installation process again.

everything are updated. all hp drivers are installed.

basically I cannot run any heavy loaded software while GPU default is 150w and CPU is 45w.

tried comfort mode, default mode with max fans on both. didn't help.

event viewer shutdown reason = unexpected and audit 0.

Could anyone help me?

1 REPLY 1
Jsmith6
Author
New member
3 1 0 0
Message 2 of 2
Flag Post
HP Recommended

Updates:

I put bios in default settings.

Ran the EFI diagnostics in both bios and windows mode. No errors.

0 Kudos
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation