Locked topic

This topic has been locked due to inactivity for a long period of time. If you have a question, please create a new topic by clicking here.
Highlighted
awparker Student
Student
1 0 0
Message 1 of 2
429
Flag Post
HP Recommended

Need to disable TLS 1 for RGS Sender Service

RGS Sender
Microsoft Windows 7 (64-bit)

I'm currently running RGS Sender 6.0 and 7.2 on different nodes. I just got a security warning from our internal computing support that these accept TLS 1.0 protocol which I must remove. I looked at the current RGS version 7.5 but I didn't find anything on the TLS support. If I upgrade which I will do anyway, will thsi eliminate the unsecure TLS 1.0? Or can someone give me an idea of how to turn off TLS 1.0.

                                                                 Thanks

1 REPLY
Grad Student Grad Student
Grad Student
255 17 24
Message 2 of 2
358
Flag Post
HP Recommended

Need to disable TLS 1 for RGS Sender Service

Here is the info on how to disable TLS 1.0.  Also, there are some caveats here.  RGS 7.5.1 should already address this but it is  at least a month out.  Let me know if this does not resolve your issue.

 

Everything from RGS 5.4.8 to RGS 7.3.3 would use TLS 1.0. Disabling older protocols will break backward compatibility. RGS 7.4 and 7.5 uses TLS 1.2.

 

If the you want to disable TLS 1.0, you can add the following settings to the sender ICE config file (in the directory where RGS is installed you will see a file called "config")  and then restart the sender system.

 

IceSSL.Protocols=tlsv1_2

IceLive.Protocols=tlsv1_2

 

You should use an RGS 7.4 or 7.5 receiver as well.

I work on the behalf of HP.

I work on behalf of HP
0 Kudos
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation