cancel
Showing results for 
Search instead for 
Did you mean: 
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
  • ×
    Information
    Fix Windows 10 Update Issues

    Resolve Windows 10 or update issues on HP computer or printer– Click Here

  • post a message
Highlighted
New member
1 0 0 0
Message 1 of 5
757
Flag Post

No audio when using RGS

HP Recommended
HP Z820
Linux

Hello,

I'm unable to hear audio from the remote machine when using RGS. For example playing an audio file or using Firefox, neither will play audio through RGS.

I'm using Windows-10 to RGS into a CentOS-7 through a VPN.

The CentOS-7 has HP Remote Graphics Sender Version: 7.6.1.19438  |  Build Date: Apr 5 2019 installed.
The Windows-10 has  HP Remote Graphics Receiver  Version: 7.7..0.20876 |  Build Date: Apr 5 2019 installed.


Things we tried but didn't work:
- set rgsenderconfig:
Rgsender.Audio.IsEnabled=1
Rgsender.Audio.Linux.RecorderApi=alsa
Rgsender.Audio.Linux.DeviceName=plughw:0,0
- Enabled logging Rgsender.Log.Filename=rg.log



Sender Log: 

 

03-17-20 17:36:41 28615(2626328320) DEBUG - HprAudio::createMixer - creating pulse mixer for volume monitoring
03-17-20 17:36:41 28615(2626328320) DEBUG - PulseSession::destroyMainloop
03-17-20 17:36:41 28615(2626328320) ERROR - RecorderSubsystem::createRecorderAndMixer - createMixer failed, volume monitoring disabled
03-17-20 17:36:41 28615(2541741824) DEBUG - KeyboardCodeMap::switchSystemType - System map: duplicate code 107 detected, ignoring. 
03-17-20 17:36:41 28615(2541741824) DEBUG - KeyboardCodeMap::switchSystemType - System map: duplicate code 107 detected, ignoring. 
03-17-20 17:36:41 28615(2541741824) DEBUG - SenderSessionIceImpl::createKeybdMouseDevice: calling createServant to start device session
03-17-20 17:36:41 28615(2541741824) DEBUG - IceProxyBuilder::getLocalIpAddressFromConnection: localIpAddress: 10.30.4.101
03-17-20 17:36:41 28615(2541741824) DEBUG - IceProxyLocalConnectionFilter::transform: keeping endpoint livessl -h 10.30.4.101 -p 42966 -t 30000
03-17-20 17:36:41 28615(749586176) DEBUG - AlsaRecorder::startRecording: using audio device plughw:0,0
03-17-20 17:36:41 28615(749586176) DEBUG - AlsaRecorder::startRecording: actual buffer time (usec): 120000
03-17-20 17:36:41 28615(749586176) DEBUG - AlsaRecorder::startRecording: actual period time (usec): 40000
03-17-20 17:36:41 28615(749586176) DEBUG - AlsaRecorder::startRecording: rate (samp/sec): 44100

 



Here's more technical info on the audio driver we have, if it helps:

 

 

➜ lsb_release -a
LSB Version:	:core-4.1-amd64:core-4.1-noarch
Distributor ID:	CentOS
Description:	CentOS Linux release 7.6.1810 (Core) 
Release:	7.6.1810
Codename:	Core

➜  lspci -nn | grep -i 'audio'
00:1b.0 Audio device [0403]: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller [8086:3a3e]
42:00.1 Audio device [0403]: NVIDIA Corporation GP102 HDMI Audio Controller [10de:10ef] (rev a1)

➜  yum list installed | grep -i 'audio'
alsa-plugins-pulseaudio.x86_64   1.1.6-1.el7              @base                 
audiofile.x86_64                 1:0.3.6-4.el7            @base                 
audiofile-devel.x86_64           1:0.3.6-4.el7            @base                 
jack-audio-connection-kit.x86_64 1.9.9.5-6.el7            @epel                 
pulseaudio.x86_64                10.0-5.el7               @anaconda             
pulseaudio-gdm-hooks.x86_64      10.0-5.el7               @anaconda             
pulseaudio-libs.x86_64           10.0-5.el7               @anaconda             
pulseaudio-libs-glib2.x86_64     10.0-5.el7               @anaconda             
pulseaudio-module-bluetooth.x86_64
webrtc-audio-processing.x86_64   0.3-1.el7                @anaconda 

 

 


Thank you,
Asi


 

4 REPLIES 4
Highlighted
New member
2 2 0 1
Message 2 of 5
Flag Post
HP Recommended

I'm sorry to see that there's been no response so far. I've been struggling with this as well, but with RemoteBoost v20 on Ubuntu 20.04. So far I have tried the same exact steps you have, following the official documentation as best I can. I suspect I'll need to read up on Pulse or ALSA documentation before I get any more movement with this.

 

Asi, is there any chance you were able to figure this out since your first post?

Reply
0 Kudos
Level 4
Level 4
47 47 7 10
Message 3 of 5
Flag Post
HP Recommended

For audio on Ubuntu 20, we found an issue where audio wouldn't play and it is planned to be fixed in the next patch release of Remote Boost.

I am an HP employee
Highlighted
New member
2 2 0 1
Message 4 of 5
Flag Post
HP Recommended

Thanks for chiming in, Becky. That's... weirdly, kind of a relief! Been banging my head on a wall for the past few hours, good to know I can stop.

 

Any sense of when the next release will be available?

Highlighted
Level 1
11 7 0 1
Message 5 of 5
Flag Post
HP Recommended

Hi Becky.... Has the update to HP Boost with full audio support for Ubuntu 20LTS been released yet?

Reply
0 Kudos
Be alert for scammers posting fake support phone numbers on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation