cancel
Showing results for 
Search instead for 
Did you mean: 
SomeGEG
New member
3 2 0 0
Message 1 of 5
387
Flag Post

Some rgreceiverconfig settings not applying

HP Recommended
Microsoft Windows 10 (64-bit)

I've noticed that a few option don't apply from the rgreceiverconfig file. In my config file I have set the following two options:

Rgreceiver.Audio.IsEnabled=1

Rgreceiver.ImageCodec.IsH264Enabled=1

 

But, when I open ZCentral Remote Boost and examine the Options, "Performance > Enable AVC on Sender" & "Audio > Stream Audio from Sender" are still unchecked.

 

Conversely, if I enable these option in the application then modify the config file to disable "=0" these settings, when I re-open the application and examine the Options they are still checked.

 

So setting these options in the config file has no effect on the application. Is this a bug? I'm trying to deploy fully configured and locked down config files to our 70 'work from home' employees so I don't have to walk them through settings one page at a time and to keep them from playing with settings that could create negative performance experiences. 

4 REPLIES 4
Lizzy_G
Level 5
Level 5
120 117 17 20
Message 2 of 5
Flag Post
HP Recommended

Hi there,

 

Not a bug, but a matter of hierarchy. (You can read more on the User's Guide- attached - page 58)

 

 If you'd like to prevent the Receiver UI from overriding values set in the rgreceiverconfig file, you as an admin would have to lock these properties in there, by making them immutable. (More on page 74 of the User's Guide).

 

e.g. Setting the following properties will lock any value set for Rgreceiver.Audio.IsEnabled and Rgreceiver.ImageCodec.IsH264Enabled:

 

Rgreceiver.Audio.IsEnabled.IsMutable=0

Rgreceiver.ImageCodec.IsH264Enabled.IsMutable=0

 

This will also prevent any changes being made by your users in the receiver UI.

------------------------
I work on behalf of HP.
Was this reply helpful? Yes No
SomeGEG
Author
New member
3 2 0 0
Message 3 of 5
Flag Post
HP Recommended

I have set the ISMutable=1 and set the IsH264Enabled=1.

 

But, if the user previously had the AVC setting to off or a previous config file had the setting to off, changing it as above the setting is still off.

Was this reply helpful? Yes No
Lizzy_G
Level 5
Level 5
120 117 17 20
Message 4 of 5
Flag Post
HP Recommended

So, what you need in the rgreceiverconfig file is:

 

Rgreceiver.Audio.IsEnabled=1

Rgreceiver.Audio.IsEnabled.IsMutable=0

 

Rgreceiver.ImageCodec.IsH264Enabled=1

Rgreceiver.ImageCodec.IsH264Enabled.IsMutable=0

 

The new values are read by the receiver upon startup, meaning that the user needs to close and reopen the receiver to pick the new values.

 

------------------------
I work on behalf of HP.
Was this reply helpful? Yes No
SomeGEG
Author
New member
3 2 0 0
Message 5 of 5
Flag Post
HP Recommended

Is not working.

 

This is in the rgreceiverconfig file:

Rgreceiver.ImageCodec.IsMutable=0

Rgreceiver.ImageCodec.Quality=65

Rgreceiver.ImageCodec.IsBoostEnabled=1

Rgreceiver.ImageCodec.IsH264Enabled=1

Rgreceiver.ImageCodec.UseGPU=1

Rgreceiver.Experience.IsMutable=0

 

And this is what we see in the options window:

Screenshot 2020-10-29 160859.jpg

 

Enable Advanced Video Compression on Sender is NOT Checked and because of the IsMutable=0 it cannot be checked.

Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation