cancel
Showing results for 
Search instead for 
Did you mean: 
patatero
New member
2 1 0 0
Message 1 of 4
465
Flag Post

ZCentral connection swaps keyboard symbols

HP Recommended
Microsoft Windows 10 (64-bit)

Hi!

 

I'm having some problems at work, because we use ZCentral to connect our machines remotely. 

First, the workstations:

- My laptop, windows 10 and ZCentral Remote Boost Receiver version 20.0.0.23427.

- Machine1, with RHEL 6.10 and ZCentral Remote Boost Sender version 20.0.0.23427.

- Machine2, with RHEL 7.8 and ZCentral Remote Boost Sender version 20.0.0.23427.

 

Now, the problem: 

When i connect my laptop with Machine1, the keyboard works normally, but when I connect to Machine2, something changes and the keyboard swaps the symbols. I use an Spanish keyboard, and when i press Shift+2, it should print ' " ', and it prints " @ ", or when I press Shift+0 it prints " ) " and not " = ". It may be a layout problem, because i don't have the " ñ ": when i press "ñ", it prints " ; ".

 

Is something strange and only happens in Machine2, still don't know why. 

Please tell me something if u can help me (or "us", we are two employees with this problem) , cause is too hard to work this way.

 

Thanks!

3 REPLIES 3
KellyRGS
Level 7
Level 7
679 670 52 66
Message 2 of 4
Flag Post
HP Recommended

On Remote Boost, the sender decides the language layout for keyboards.  On the sender that is working versus the two that are not, is the language layout different?  In the old RGS solution, you had to have the language selection on both sender and receiver.  

 

The one thing you could try is this property.  Add this to the rgreceiverconfig file, relaunch the receiver if you have it open. 

The rgreceiverconfig file is located at C:\Program Files\HP\Remote Graphic Receiver.  Open file with administrative privileges.  Does this resolve the issue?  

 

Rgreceiver.KeyboardMapMode=1 

I am an HP employee.
Was this reply helpful? Yes No
patatero
Author
New member
2 1 0 0
Message 3 of 4
Flag Post
HP Recommended

Hi Kelly,

 

I tried this solution in the past (I read it in an older post) and it didn't work (I already have this line in the config file).

Both RHEL languages are en_US, and both are working with the Spanish layout in the keyboard.

 

Was this reply helpful? Yes No
KellyRGS
Level 7
Level 7
679 670 52 66
Message 4 of 4
Flag Post
HP Recommended

Okay, I have a tool that I would like you to run, but I need to send it over in a drop box.  I will reach out in a PM shortly.

Kelly

I am an HP employee.
Was this reply helpful? Yes No
Warning Be alert for scammers posting fake support phone numbers and/or email addresses on the community. If you think you have received a fake HP Support message, please report it to us by clicking on "Flag Post".
† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the Terms of Use and Rules of Participation