• ×
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
  • ×
    Information
    Need Windows 11 help?
    Check documents on compatibility, FAQs, upgrade information and available fixes.Windows 11 Support Center.
  • post a message
HP Recommended

Hi,
I have both a Sabrent SB-ROCKET-2TB and a Sabrent SB-ROCKET-1TB NVMe drive for my HP Omen 2020 Laptop.

 

Both these drives were used without issue in a desktop until I got this laptop about a week or two ago.

 

To try and keep this as simple as possible, with the SB-ROCKET-1TB installed the Laptop works exactly as you would expect.

 

However, if i replace the SB-ROCKET-1TB with the SB-ROCKET-2TB or add the SB-ROCKET-2TB as a second drive the laptop, it will wait for upwards of 2-3 minutes at POST but ONLY AFTER A RESTART of the laptop from within Windows as an example and NEVER from a powered off state.

 

Powering up the laptop from power off sees the system load perfectly every time with the 2TB installed.

 

To rule out Windows or any other configuration issues, i removed the SB-ROCKET-1TB, created an Ubuntu Live USB, booted from that into Ubuntu Live and then restarted from within Ubuntu and the issue still happens where it sits at POST for a long time with the 2TB installed. Meaning the 2TB isnt even used, its only installed and yet it still happens.

 

Power Off/On the laptop and it starts to load immeditely. I have the latest available firmware installed - version 13A.

 

Can you advise?

 

Thanks

 

† The opinions expressed above are the personal opinions of the authors, not of HP. By using this site, you accept the <a href="https://www8.hp.com/us/en/terms-of-use.html" class="udrlinesmall">Terms of Use</a> and <a href="/t5/custom/page/page-id/hp.rulespage" class="udrlinesmall"> Rules of Participation</a>.